W3 Total Cache
DONOTMINIFY constant is defined (17 posts)

  1. mark_m
    Posted 3 years ago #

    W3TC adds "Minified using disk: basic (DONOTMINIFY constant is defined)" to every page in the code of my site, so minifying is not working. But I did NOT do anything to NOT minify the site.
    I have discovered that it has to do with my theme, because with another theme minifying does work.
    I've used this theme for a longer time and previously minifying worked well! I really don't know what has changed. I've updated several plugins of course, but when I disable them (exept W3TC) then minifying still doesn't work.
    Can anybody help me?


  2. teo.jurado
    Posted 3 years ago #

    +1.. me too.. and the same with (DONOTPAGECACHE).... Vers. 3.4.1 of WordPress...

  3. mark_m
    Posted 3 years ago #

    Oh yes, I have to add this:
    WP v3.4.1
    W3TC v0.9.2.4
    and my theme is an older modified version of the Roots theme.
    I only have troubles with minification, not with caching.
    On another site with the same theme I have no problems.

  4. seriocomic
    Posted 3 years ago #

    Also had this showing for a site that was working fine previously - no recent changes other than normal updates to WP + Plugins (only running Yoast's)

  5. Chris Barrett
    Posted 3 years ago #

    Thank you @seriocomic - your comment was a lightbulb.

    I, too, am running Yoast's SEO Plugin.

    Guess what? Tried deactivated Yoast's SEO Plugin and suddenly the DONOTMINIFY disappears...

    So, what the heck did Yoast do?!?! I'm going to over his support thread to complain! :)


    UPDATE: After deactivating WordPress SEO by Yoast and reactivating, the DONOTMINIFY is no longer in the page source and W3T Cache is minifying correctly again.



  6. teo.jurado
    Posted 3 years ago #

    Good!!.... I updated Yoast 2 or 3 days ago...Going to try your solution @Chris...

  7. mark_m
    Posted 3 years ago #

    I'm running WordPress SEO by Yoast too.
    Indead, when deactivating that the DONOTMINIFY disappears, but it comes back when I reactivate it :-(
    Let's go to the WordPress SEO forum and hope Yoast will fix this soon.

  8. seriocomic
    Posted 3 years ago #

    Deactivating the SEO Plugin fixes the problem for me too.

    However, reactivating reintroduces the problem.

    The funny thing is that I have several sites running W3TC and WP SEO - only one site is affected by this bug...

  9. mark_m
    Posted 3 years ago #

    Same Same to me seriocomic.
    No problems with other sites with those plugins.........not yet?

  10. teo.jurado
    Posted 3 years ago #

    Good.... Updated now to the last Yoast.., same problem... not fix for now

  11. Chris Barrett
    Posted 3 years ago #

    Perhaps a piece of the puzzle I didn't mention before for the fine folks at W3T Cache (who I'm sure are working to fix this)...

    On a local WAMPServer version of my site, I already had an active version of W3T Cache and Yoast's SEO when I did the update for Yoast. The problem never happened there.

    The problem only happened when I completed the W3T Cache setup on WAMPserver and then tried to install and activate W3T Cache on the live site - which was running an older version of Yoast's SEO and did not initially have W3T Cache installed.

    When I installed W3T Cache on the live site, and then applied the update for Yoast's SEO - then the DONOTMINIFY issue started on the live site. So, I wonder if the installation/update sequence comes into play?

    Good luck everyone with this rather annoying issue!

  12. mark_m
    Posted 3 years ago #

    The problem seems to be solved here now.
    After I updated to the latest version, I deactivated the very annoying tracking option and flushed all caches. When I checked my site the DONOTMINIFY code was gone.
    I'm not shure it has to do with deactivating tracking or with just the latest update.
    I hope that all of you will get it fixed soon too!

  13. teo.jurado
    Posted 3 years ago #

    Yes @Mark!! The problem was gone...... Thanks!!!!

  14. Hayden James
    Posted 3 years ago #

    I can confirm as per Mark's post, upgrading to fixes this issue but you have to uncheck "Allow tracking of this WordPress installs anonymous data." from Yoast's settings as it will be re-enabled after upgrading plugin.

  15. Hayden James
    Posted 3 years ago #

    Would have been nice if they added that to changelog :p

  16. astrasuite
    Posted 3 years ago #

    Thank you! Another problem solved, and I would not have thought it was Yoast, again.

  17. krzysko
    Posted 2 years ago #

    Add this to wp-config.php

    define('DONOTMINIFY', false);

    solve the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic