Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Disable W3C for a page and subpages

Viewing 15 replies - 1 through 15 (of 15 total)
  • If you look in the FAQs of the plugin you will find a couple of things you can do to remove caching from specific pages.

    How can I prevent caching directly in my templates etc?

    Several constants are available for these purposes:

    define(‘DONOTCACHEPAGE’, true);
    Disables page caching for a given page.
    define(‘DONOTCACHEDB’, true);
    Disables database caching for given page.
    define(‘DONOTMINIFY’, true);
    Disables minify for a given page.
    define(‘DONOTCDN’, true);
    Disables content delivery network for a given page.
    define(‘DONOTCACHCEOBJECT’, true);
    Disables object cache for a given page.

    Thread Starter John Robertson


    Hmm still a lot of work since it’s a semi automatic job board. I’d have to do that for every single job page created :/ Well I guess it’s not a huge issue with the cache on.

    Plugin Contributor Frederick Townes


    You can use regular expressions in the never cache the following pages box on the page caching settings tab to handle these cases.

    Dea Frederick. So if I want to disable caching for the page:

    Do I add its full path to that box?

    Also, if I am to use “define(‘DONOTCACHEPAGE’, true);”.. where do I put it? is it in a “custom field” of the page ?

    @iceq: Do not add the full path. Just add /

    Thanx , I will try that.

    Is there a way I can make sure it is indeed NOT cached ?

    Sure- look at the page source. The W3TC notes at the bottom of my non-cached pages include:

    “Page Caching using disk (enhanced) (request URI is rejected)”

    I found no “request URI is rejected” at all.
    Using firefox (I am logged into my WP through it), I get:

    Minified using disk
    Page Caching using disk (user is logged in)
    Served from: @ 2011-04-24 14:14:22 –>

    With IE (not logged in), I get:

    Minified using disk
    Page Caching using disk (cookie is rejected)
    Served from: @ 2011-04-24 14:15:41 –>

    can I please make sure it is not cached?
    (same page:


    Don’t know how you can be “sure”. Maybe someone more knowledgeable will reply. Except that I’m not having any problems with my pages that are excluded from caching.

    Sorry I meant to say, “Can YOU please make sure it it not cached, by viewing that page’s source?

    As I showed, the source of the page includes no “request URI is rejected”. So does this not mean that it’s still cached ?

    You can check it yourself. Just right click on the page and select “view source” (when you’re not logged in). On this end it reads:

    <!– Performance optimized by W3 Total Cache. Learn more:

    Minified using disk
    Page Caching using disk

    Served from: @ 2011-04-24 16:34:01 –>

    Thank you again. Yes, that is what I did, and still I did not see that it says anywhere “request URI is rejected”, and that is why I asked you to (please) verify that.

    Was there ever a resolution to know for sure if a page is not being cached? Is it the inclusion of the “request URI is rejected” language that says it’s not cached? If that’s not there, can we assume it’s being cached?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: W3 Total Cache] Disable W3C for a page and subpages’ is closed to new replies.