Support » Plugins and Hacks » [Plugin: W3 Total Cache] Directory structure problem

[Plugin: W3 Total Cache] Directory structure problem

  • I just tried to upgrade this plugin automatically to 0.9. When trying to reactivate I got a fatal error. I had to delete the W3 files completely so I could do a fresh manual install. When looking at the files downloaded and following the install directions things aren’t matching up. Also doing an automatic install through the admin panel puts all of the files in the plugin “wp-total-cache” folder within the plugin directory. As I understand some of the files so elsewhere correct? Doing an install as is will not allow me to activate the plugin. Can someone check the zip file and see if the directory structure is set up properly within that and see if the instructions are up to date please?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Frederick Townes


    What is the fatal error you see?

    When I follow the internal links to upgrade it appears the install is successful. The plugin cannot be activated again after that. It just says fatal error when I try. I deleted the old plugin manually and manually installed and got the same error. I had to re-download the last stable release and use it and it worked fine.

    Hello, my problem is very similar.
    Used auto-update that ended saying: Unable to remove old version (or something).

    However now W3 Total Cache is no longer visible in the WP-Menu nor in the WP-Plugin page.
    The directory structure on the server still exists (Perm. 777).

    I am reluctant to remove the existing directory and install from scratch. Would that be the solution ?

    As far as my problem is concerned to be unable to upgrade to 0.9.1, I have removed the “old” directory (not any php files higher in the structure) and installed 0.9.1 as “first time”.

    This went okay. I had to change wp-config.php and .htaccess (manually as instructed) and then it went okay.

    Be aware that automatically upgrade did however not work.
    Thanks again,

    Plugin Author Frederick Townes


    If you’re having upgrade/update issues you have to remove the plugin completely and install from scratch. Nothing has been changed in the plugin for ~4 months with regard to how activation works. Every upgrade some users have a challenge. Because W3TC has to copy some files into their proper locations, there can be surprises.

    Unfortunately that is the nature of how caching is implemented, so I appreciate your patience and understanding.

    I did delete all of the old files and manually installed the latest release. Same problem. I had to re-download the last stable release and use it and it worked fine.

    Plugin Author Frederick Townes


    Please submit bug submission forms if you haven’t already.

    Any way to access the bug submission form without the plugin installed?

    Plugin Author Frederick Townes


    No. I guess you’ll have to send me an email through my site.

    lol, okay. Thanks. I appreciate it.

    Plugin Author Frederick Townes


    You’re welcome.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: W3 Total Cache] Directory structure problem’ is closed to new replies.