WordPress.org

Forums

W3 Total Cache
[resolved] Default /nginx.conf location (11 posts)

  1. spencerlim
    Member
    Posted 3 years ago #

    May i know where is the location of /nginx.conf file ? i tried to put on /var/www/website/ or /var/www/website/web and set them to chmod777 but also cannot use the auto-install.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Pothi
    Member
    Posted 3 years ago #

    You don't have to put it on a particular location. W3 Total Cache automatically puts it in WP_HOME (from what I know). You also don't have to change it to 777. But, you should include this file's physical location in your site's Nginx configuration and then reload (or restart) the Nginx server to apply the changes in the Nginx configuration.

  3. spencerlim
    Member
    Posted 3 years ago #

    No, it doesn't solve the issue. i was created one file in my /var/www/domain/nginx.conf
    and include the line "include /var/www/domain/nginx.conf;" in available site config. restarted the nginx but the problem still there..

  4. Pothi
    Member
    Posted 3 years ago #

    but the problem still there..

    May I know what that problem is?

  5. spencerlim
    Member
    Posted 3 years ago #

    Disk enhanced page caching is not active. To enable it, add the following rules into the server configuration file (/nginx.conf) of the site above the WordPress directives . Or if permission allow this can be done automatically, by clicking here: .

    Disk enhanced page caching is not active. To enable it, add the following rules into the server configuration file (/nginx.conf) of the site . This can be done automatically, by clicking here: .

    Browser caching is not active. To enable it, add the following rules into the server configuration file (/nginx.conf) of the site . Or if permission allow this can be done automatically, by clicking here: .

  6. Pothi
    Member
    Posted 3 years ago #

    Okay, try adding those rules directly into the your site's main Nginx configuration file. Please make sure they are at the top of the location blocks. For example...

    server {
      server_name domain.com;
      root /path/to/wordpress;
    
      # W3 Total Cache rewrites to be written here
    
      location ~ \.php$ {
        # directives to process PHP
      }
    
      location / {
        try_files $uri $uri/ /index.php;
      }
    
    }

    I hope this helps.

  7. spencerlim
    Member
    Posted 3 years ago #

    it still couldn't be solve, Thx anyway.

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Would you like professional support @spencerlim?

  9. spencerlim
    Member
    Posted 3 years ago #

    No, Thx. it's too expansive and overprice. i just want to know how to fix it. because i got multiple wordpress having the same problem. Thx

  10. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Price is relative. I'm not trying to sell you something, but it's not trivial to investigate your issue without more information. Good luck

  11. spencerlim
    Member
    Posted 3 years ago #

    May we discuss further in email ? Thx
    spencerlim@itechspark.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic