Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Compatibility Test Errors

  • Resolved Sarunas



    Then I run compatibility check it shoes me some red fields:

    Server Modules & Resources:
    PHP Version: 5.2.13
    PHP Timezone: Not set
    Web Server: Apache
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Mimetype
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected

    WordPress Resources
    /home/mywpusername/public_html/wp-content: Write-able
    /home/mywpusername/public_html/.htaccess Write-able

    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

    What I done wrong?

    (bolded problems)

Viewing 15 replies - 1 through 15 (of 22 total)
  • I think you do nothing wrong, simply this is your webserver configurations.
    The test says alsto that “Not detected” is not bad but OK; opcode cache and memcache extension are powerful solution but not required for a normal hosting.

    I came here to post about the apache modules not being detected.

    My server has all those modules yet it shows up as Not detected. So I’m guessing something is wrong with the detection script or the script just doesnt work very well.

    This detection should be fixed or removed as I can see many people coming to me saying “mod_* is not detected on my wordpress! install this!”. It gives people a sense that its not installed when it actually is.

    W3 total crash… 🙂

    Yes, I have normal shared host. Maybe it is not a problem at all, but I don’t see any changes in my sites speed, sometimes it is even low score 2-3 points regarding Yslow, then script installed. I’m totally confused for now :/ maybe the best solution for me would be Plugins- uninstall- delete these files -yes to all?

    Thanks for replaying!

    I have similar compatibility check results to you bumerangas and W3TC ( is working fine. You are checking your scores when you are not logged in?

    No, I even tried different browsers, but results a just the same – and before checking always run ccleaner. Sometimes results just the same, sometimes + 2, sometimes -3 on different sites. Anyway results seems not very bad from 79 to 87 (Yslow).

    So, looks like for me this plugin doesn’t works. :/ Maybe I will try again in a day or two.

    Plugin Author Frederick Townes


    When PHP is not run as an apache module it is difficult to detect the modules, so that’s why the test says not detected. It doesn’t said not installed or failed, it says not detected. There is no “problem” with the results of that test. There is no such thing as a perfect test script because of the countless things hosts can do with their servers. It’s designed to help users troubleshoot obvious issues. If something is not detected you have to ask your host or check manually.

    So, looks like for me this plugin doesn’t works. :/ Maybe I will try again in a day or two.

    There are lots of reasons why you cannot get an A YSlow score, asking for help without even telling people your domain name is not going to allow anyone to help you at all.

    No plugin can automatically resolve all of the possible issues in any site and this plugin does not make that claim. I’m not sure where your expectations are coming from.

    Also don’t forget that a perfect YSlow score does not mean your web site is fast. There are lots of other tests to do to measure different metrics.

    I also had some issues with getting W3 to work. Took my like 3 days of tweaking, but now the result is awesome.

    I used to run supercache and recently used the preload mode, when I changed to w3 I just noticed I had like 5 sec response time suddenly. I had to learn on apache, php, mysql, used a virtual host as cdn but response time was still slow.

    I learnt a lot about optimizing these tools settings, which isn’t so easy on a vserver with plesk 😀

    But these 3 days were totally worth it and I was able to get my site way faster than it had been with supercache before. Probably more because of installing tools like xcache, removing old plugins than pure w3 ownage, but I can definitely see its advantages for a busy website and I am glad I learnt a bit about it.

    On a sidenote, thanks for delivering such an outstanding plugin.

    Plugin Author Frederick Townes


    You’re welcome.

    Hi Frederick – I’m getting the following messages from the Compatability check:

    PHP Timezone: Not set
    Memcache extension: Not installed
    WP_CACHE define: Not defined

    As you can see it says Memcache is Not Installed – but my host said they did install it – this is not a case of W3 saying Not Detected, it’s actually saying Not Installed.

    I’m not too bothered about the timezone thing, but if you know how to set this let me know.

    The last bit seems important – how do I “define” WP_Cache?

    Appreciate your help.

    Plugin Author Frederick Townes


    The compatibility test is very simple, if it cannot find the memcache PECL extension then it is not installed. If this is actually a bug then you can submit a bug submission form from the support tab of the plugin.

    Add define( 'WP_CACHE', true ); to the top of the wp-config.php

    thanks, got the compatability test to work for memcache now after contacting my host again with the info you provided, thanks.

    Plugin Author Frederick Townes




    I’m adding on to this thread because I have similar questions. I understand that the plugin is complex beyond my minimal technical expertise, but I hope you can clarify if any of the following items are things I should act upon or if everything is OK. I have tried to find the answers in the FAQ and this forum but have failed.

    FYI, my site uses WP 2.9.1 & is hosted with PHP Version: 5.1.6. I changed permissions to the .htaccess and wp-content as needed during install (and/or changes to settings), but changed them back after the install as I understand that this is the preferred security setting.

    I ran the compatibility check and received the following warnings:

    PHP Timezone: Not set
    Opcode cache: Not installed
    Memcache extension: Not installed
    /docs/Vendors/office/html/wp-content: Not write-able
    /docs/Vendors/office/html/.htaccess Not write-able

    Mime type detection: Mimetype
    Open basedir: On: /docs/Vendors/office:/var/www/awstats:/usr/share/phpmyadmin

    Thank you for your time & for developing the plugin.

    Chris Olbekson


    Level 12 Bug Squasher & Forum Moderator

    FYI, my site uses WP 2.9.1 & is hosted with PHP Version: 5.1.6.

    FYI 2.9.1 has security issues. If your going to stay with the 2.9 branch update to 2.9.2

    Plugin Author Frederick Townes


    @efa, there’s nothing wrong with that compatibility check if you’ve already finalized your installation. I would need to know more about your server and optimization objectives to determine if there are any action items for you. Do you have more specific questions?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: W3 Total Cache] Compatibility Test Errors’ is closed to new replies.