W3 Total Cache
[resolved] Cloudfront CDN and deploy not working (w3tc-dev, wp-2.9.2) (5 posts)

  1. blau
    Posted 6 years ago #

    I use wordpress 2.9.2, Thesis 1.7 theme and w3TC development version (downloaded 23/06/2010).

    The cache seems to work (I see the banner at the bottom of the html source), however:

    1) Static files are not served via Cloudfront (S3 and Cloudfront are configured and confirmed working, files have been uploaded), just from the main site.

    2) on the admin page I see a Preview and Deploy button, but deploying gives an error (unable to deploy).

    What can I do to pinpoint the issue?

    Edit: I still get an:
    "Content Delivery Network Error: The "Access key", "Secret key", "Bucket" and "Replace default hostname with" fields must be populated."
    but this has occurred before (a former dev version of the plugin) and the CDN settings are saved in the page.


  2. blau
    Posted 6 years ago #

    Ok, the issue seems to be that I am able to preview changes (CDN works in preview mode) but I get an "Unable to deploy preview settings." when I deploy.

    However, if I "preview", "deploy" (get the above error) and "empty all caches" the cache seems to work and I see static content being serverd off the CDN CNAMEs (static1-2-3.mysite.com) when logged in as admin.

    If I see the site as a general user however I am not served static content via CDN, but via the main site.

    I am using an development version downloaded about June 23 9 am UTC .

  3. Frederick Townes
    Plugin Author

    Posted 6 years ago #

    Please check your permissions and deactivate + reactivate the plugin, W3TC is unable to write the configuration file.

  4. blau
    Posted 6 years ago #

    Thank you Frederick: it worked. So simple.

  5. Frederick Townes
    Plugin Author

    Posted 6 years ago #


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic