Support » Plugins and Hacks » [Plugin: W3 Total Cache] CDN url replacement stops working

[Plugin: W3 Total Cache] CDN url replacement stops working

  • Hi,
    First of all, I would like to thank the developers for the great plugin. I am fairly new to WordPress and I was at first disappointed with it’s performance compared to other CMS’s I am used to, until I found this plugin.

    However , I have a problem getting W3 Total Cache to work with Amazon S3.
    I have set up the CNAME settings correctly, uploaded the theme, wp-includes and minimify files and the plugin successfully replaced all the URI of theses files to my subdomain that I created for s3 (s3.mywebsitename.com).
    Two days later, I comeback to visit my website with my browser and surprise: the files are no longer pointing to s3.mywebsitename.com but to mywebsitename.com.
    I tried disable / re-enable CDN settings in W3 Total Cache and clear the cache, no luck. Then I decided to remove the plugin and re-install it, that did the job and the files addresses point to s3.mywebsitename.com.

    Two days after that, I comeback again and the same story again, my files point to my main domain instead of my s3 subdomain.

    What is the problem, how to fix this?

    I am running WordPress 3.0.3 on 1and1 shared hosting and using Amazon S3.

    Happy Holidays!

Viewing 15 replies - 1 through 15 (of 33 total)
  • I am actually having the same issue, on both a VPS and a dedicated server. Any help is appreciated.

    May or may not be related – I’m also on 3.0.3 and using S3, mine has uploaded all of the theme files to Amazon but never replaces the URL for them when you load the page.

    For example, if you view the background image it is still shown as http://www.mysite.com/image.png instead of static.mysite.com/image.png – however, the images in the posts are on the CDN. If you manually change the URL in the address bar from www to static then the file is there. Clearing the cache etc does nothing.

    Everything seems to work except possibly the URL replacement…?

    Yes xsquared_uk your problem mirrors ours. I wonder does anyone have this issue in WordPress 2, or perhaps 3.0-3.0.2??



    Is there a solution to this problem? I’m having the same issue, but on my site it switches back to point at my host within 20 min.

    [Posting this here as well because I noticed the other forum entry was marked as “Resolved”.]

    Another data point — the same thing happens to me. WordPress 3.0.4 with W3TC and Amazon CloudFront. I don’t have to reinstall the plugin; simply disabling/re-enabling gets W3TC to rewrite URLs to the CDN. Then at some point it stops rewriting URLs.

    Check to make sure your Unsuccessful file transfer queue is not full of errors. If this queue is full of errors, it may prevent some files from using the cdn.

    @western592, this is the common cause of the problem. I recommend origin pull providers.

    I had similar problem where auto CDN urls worked and then checked back a couple of days later to find them not pointing to CDN.

    Solution: Deactivate and reactivate the plugin.

    The CDN urls are working for items that were part of the wp-includes and theme uploads, but not for the files contained in folders under Custom Files. The URLS are not being replaced to the CDN, they still point to the original domain.

    For instance, under Custom File I have an entry:


    To grab files from


    Everything is uploaded flawlessly to the cdn, but none of the URL are replace when I load the web page.
    I can access the image by direct URL as well.

    I have cleared the failed queue as well as deactivated activated the plugin.

    Any thoughts why the URL replacement is not working on Custom Files?

    This is a bug which has a very easy, but somewhat tedious fix.

    If you go back and check, you will notice that only new posts are not using the CDN urls. The older ones are probably working just fine.

    To solve the problem, I just go to the CDN section in the W3 Total Cache plugin. Select the “Unsuccessful file transfers” button. Then choose “delete queue” to solve the problem. You will probably have a list of files that the plugin thinks failed to upload, but they worked just fine.

    Just a small glitch, but you have to repeat that process from time to time.

    This is how I “fixed” it:

    I went to
    –> Performance –> “CDN settings”
    –> button “unsuccessful file transfers”
    –> Delete queue

    and then uploaded the files again (which of course results in “file already exists messages”)
    –> Performance –> “CDN settings”
    –> button “Upload custom files”

    I tried both suggestions. But I still have no URL replacement for those Custom Files, and the “unsuccessful file transfers” queue is empty.

    Could it be related to the fact that these directories are *outside* of the wordpress installation folder?

    @ C B: Did you Deploy?

    If you’re on Preview-mode, test your site after ‘Deploy’ and change configuration if needed.

    Thanks fahdi, but I had deployed already. I actually went back to Preview, re-uploaded the custom files and re-deployed. But I still have no URL replacement for those custom files. Other than the custom files, everything seems to be working great.

    Hi C B

    Can you give an example of your URL structure for the custom files?

    I think I have an easy solution for you. If you can share your URL and the custom file URL.

    Fahd Murtaza

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Plugin: W3 Total Cache] CDN url replacement stops working’ is closed to new replies.