WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: W3 Total Cache] CDN Not Working Properly

[Resolved] [Plugin: W3 Total Cache] CDN Not Working Properly

Viewing 15 replies - 1 through 15 (of 30 total)
  • Your CDN is working well along with W3TC now. Just check it out.

    No, it is not working. Some of the images are being served from CD because I have hard coded them.
    However, images that W3 Total Cache should automatically serve from CDN are not being served from there, instead they are being served from local server!

    Wait, it has started working. I had read in separate thread that deactivating and then activating the plugin again can fix the problems. I just did that and now images are automatically being served from CDN.
    Problem Solved.

    Plugin Author Frederick Townes

    @fredericktownes

    Who was your CDN provider?

    Amazon Cloudfront.

    Any updates on this? I’t not working as expected for me either. If I deactivate and reactivate the plugin it will work for some time but eventually it will stop serving files from the CDN until I deactivate and reactivate again… I am also using Cloudfront as the CDN.

    For me, it has been working well since that issue. Not noticed problem again.

    I have the exact same issue!
    After reinstalling the plugin it works for 2 days, and then at some point, stops replacing the URL pointing into my S3 subdomain.
    Described in this topic: http://wordpress.org/support/topic/plugin-w3-total-cache-cdn-url-replacement-stops-working

    Anyone knows how to fix this?

    Tom

    @tawerkheiser

    Was this actually resolved? I’m having the same problem, within 20 min or deactivating and reactivating it stops serving from my cdn.

    Another data point — the same thing happens to me. WordPress 3.0.4 with W3TC 0.9.1.3 and Amazon CloudFront. I don’t have to reinstall the plugin; simply disabling/re-enabling gets W3TC to rewrite URLs to the CDN. Then at some point it stops rewriting URLs.

    No response or action taken on this as far as I can tell, pretty bothersome. Anyone hear anything from Frederick on this at all?

    It’s still consistently happening to me across multiple sites, kind of defeats the purpose of taking the time to set this up if its not going to work.

    Yeah it seems like Fredrick is too busy to support this plugin. I’ve posted a few problems related to the CDN with multisite and even sent in a bug report through the plugin with no response.

    I’m no longer using the CDN for the time being.

    I am using cloudfront as well and everything worked ok at first but now it seems that my theme files (images) aren’t being served from the CDN any longer. I can disable/re-enable the theme and it still doesn’t work. It only seems to be serving a few items from the CDN and those are images that are in the media library.

    Check to make sure your Unsuccessful file transfer queue is not full of errors. If this queue is full of errors, it may prevent some files from using the cdn. Use the delete queue option when viewing to empty the queue.

    Looks like that was the problem. I’m not sure I would have ever figured that one out. Thanks!

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] CDN Not Working Properly’ is closed to new replies.