WordPress.org

Support

Support » Plugins and Hacks » [Plugin: W3 Total Cache] Cant delete (WP 3.3.1)

[Plugin: W3 Total Cache] Cant delete (WP 3.3.1)

Viewing 2 replies - 1 through 2 (of 2 total)
  • Same thing here . . . kind of.

    I reinstalled W3 Total Cache a few day ago, or maybe a little longer.

    Everything seemed fine at first. However . . .

    Today, for no apparent reason, when I tried to log into my blog using the sidebar login, I get a little pink box right above the login field which says “undefined”.

    I wracked my brain out trying to figure out what was going on. I strongly suspected that the problem might be W3 Total Cache, because each time that I have tried to use or install a caching plugin, I run into major problems.

    So, since I couldn’t even log in, I decided to manually remove the W3 Total Cache plugin, since the server machine sits right next to me.

    Following the instructions on this forum, I manually removed the main W3 Total Cache folder in the plugins folder. I removed all of its related files from the wp-content folder. I removed its rules from my blog’s htaccess file. I removed both parameters that I had added to the wp-config file — one for caching, and one to increase WP’s memory to 64MB.

    After doing that, I couldn’t access my blog AT ALL. All I got was an error message stating that there was an “error establishing a database connection”.

    So, I reversed everything that I just explained, and now I can access my blog again, but again, I cannot log in. I get the little pink box which says “undefined”.

    In short, I cannot even delete the plugin, or log in. 🙁

    Worse yet, this is affecting another WP blog which is part of another domain that I run on the same server. I use MAMP PRO.

    Even thought that blog does not even have W3 Total Cache installed, and never did, I cannot even access the blog, and am getting the same exact error regarding an “error establishing a database connection”.

    Since this second blog never even had W3 Total Cache installed, this suggests to me that this plugin actually did something in the mySQL databases themselves. I don’t know what or where, and much less how to fix it.

    Frederick, I gave your plugin a fair chance, and now it REALLY has me upset.

    To reiterate:

    1. With my blog, I cannot log in and get the pink box with the word “undefined”. If I remove all of W3’s parts, I can’t even access the blog and get the “error establishing a database connection” message. If I put all of the parts and rules back in place manually, it is back to the pink box.

    2. With the second blog on the other domain, I can’t even access it at all. I just get the “error establishing a database connection” message.

    Please assist at your earliest convenience.

    Thanks!

    Sorry it sounds like conflict with another plugin or theme code, these things can happen. You would have to remove the add-ins from wp-content and rename or delete the w3-total-cache directory in your plugins directory. Once done go ahead and remove the W3TC rules from your .htaccess files as well.

    I would be curious to see what errors are in your error log.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: W3 Total Cache] Cant delete (WP 3.3.1)’ is closed to new replies.
Skip to toolbar