Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Can't activate

  • Getting this error when attempting to activate it:

    Plugin could not be activated because it triggered a fatal error.

    Then, firefox gives me a pop-up and asks me to download “plugins.php”

    Any idea what could be going on here? Permissions settings? Other server config stuff?

    BTW, I installed and tested this on a test-install of WP I have on a shared server. It worked fine. The server it’s not working on is a VPS.


Viewing 6 replies - 1 through 6 (of 6 total)

    Looking around for that error message I came upon someone who mentioned that this line needs to be added to wp-config.php

    define(‘WP_CACHE’, true);

    The error message didn’t tell me to do that, so I don’t know if that’s old info.

    Also, I don’t believe that my .htaccess file is writeable. Are there any other files that need to be writable to make sure that this works (other than the /content/ and /uploads/ folders both being 777 to install).


    Hi again. Does anybody have any advice on this? It’d be much appreciated. Thank you.

    Hello again. Just checking back in to see if anybody has any advice on this? Thanks.

    Well, I added the define(‘WP_CACHE’, true);

    That didn’t work.

    I’ve also seen some mention that PHP safe mode needs to be off. Is that true as that may be my problem?

    The only other thing is that my wp-config file is stored outside the root directory. Could that be an issue? I thought since I added the define(‘WP_CACHE’, true); it wouldn’t be.

    Any help would be greatly appreciated. Thanks.

    I got an error similar to yours that turned out to be not enough PHP memory. Putting this in .htaccess solved it.

    php_value memory_limit 64M

    Also, if wp-config is outside the normal area then maybe WP isn’t seeing it at all. Have you tried moving it back?

    Plugin Author Frederick Townes


    @lunabean, I think @bobmorris60 is right. What did you find?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: W3 Total Cache] Can't activate’ is closed to new replies.