WordPress.org

Support

Support » Plugins and Hacks » [Plugin: W3 Total Cache] Cannot select S3 or CloudFront in CDN settings

[Plugin: W3 Total Cache] Cannot select S3 or CloudFront in CDN settings

  • note: I am using WPMU 2.8.1, not vanilla wordpress!

    Hello,

    I’ve just installed the W3 Total Cache plugin and it looks awesome… except, I can’t select Amazon S3 or CloudFront for the CDN settings!

    The option to do so is simply greyed (grayed?) out (disabled!) on the “General Settings” tab in the CDN section.

    Am I missing something? The FAQ says to just select this option, but I can’t!

    As mentioned above, I’m using WPMU if that helps, and I do not have any other caching or S3 plugins enabled.

    Thanks in advance,
    Alex

Viewing 5 replies - 1 through 5 (of 5 total)
  • The CURL PHP module is missing on your server. Ask your admin to install it.

    Thanks, frederick! Your solution worked.

    Perhaps this should be added to the FAQ/documentation?

    No, a notification was added to the latest release since it’s typically installed more often than not.

    Cloudfront disabled on my install. Curl is current.

    root@domU-12-31-39-0C-10-95:~# apt-get install curl
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    curl is already the newest version.

    Very frustrating – I am using ec2 with Ubuntu 10-04 lts.
    Probably something inherently wrong with the plugin –
    28/64 pass/fail on user responses with wp3.0 – not a good sign.

    Use the development version of the plugin. The current release says that it’s not compatible with WP 3.0, but users still seem to use it and most have success as the stats indicated. v0.9 is tested up through v3.1 of WordPress.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: W3 Total Cache] Cannot select S3 or CloudFront in CDN settings’ is closed to new replies.
Skip to toolbar