Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] cannot select "Host minified CSS and JS files"

Viewing 15 replies - 1 through 15 (of 15 total)
  • Have you enabled CDN in the General options?

    Yep …

    What’s also happening is that I want to combine the CSS into one file and minify it. Under non minified circumstances, the CDN sees the files and CDNs all the static content (e.g. background images and so on) but when I minify and combine into one file, it does not get uploaded to the CDN. While most images from posts and so on are uploaded, the stylesheets and background images don’t get uploaded.

    Just yesterday I did change to self-hosted “CDN” and all worked fine.

    Until today, because I added another JS and that needs to get minified and combined, too.

    After deploying the site is referencing to a file that does not exist on my ftp server….

    Very strange.

    Which CDN are you using?

    MaxCDN

    Plugin Author Frederick Townes

    (@fredericktownes)

    MaxCDN is an origin pull CDN. So if you don’t see some files being served by the CDN, you may need to add custom paths to the field of the same name on the CDN settings tab.

    oh ok not a problem.

    Plugin Author Frederick Townes

    (@fredericktownes)

    So you’re all set?

    Well it doesnt work but we discussed this in the email, once again cause NGINX was still not supported. Ill wait for v1 of your plugin

    Plugin Author Frederick Townes

    (@fredericktownes)

    Ok.

    Plugin Author Frederick Townes

    (@fredericktownes)

    Ok… Please don’t cross post, it doesn’t help other members.

    Hey Frederick,

    I have a question along the same lines but a little different. I have everything working ok on my server side. The CDN box is greyed out but all of my CSS and JS seem to be loading from the CDN fine.

    My issue is that unlike before I had the CDN, my selected javascript in the minify section isn’t loading in the footer and the CSS from the header from my CDN. I have selected all JS I want minified as:: non-blocking_Embed before </body>.

    Is that the correct setting? Should I be inputting the JS link address from my CDN into the minify settings or would that be redundant?

    Thanks for putting up with the noob q’s 🙂

    What I meant to ask was::

    should I be inputting the JS link address from my CDN into the minify settings in addition to the site-side JS or would that be redundant?

    Any help I can get from Frederick or anyone else would be awesome 🙂

    Thanks in advance for your time.

    Plugin Author Frederick Townes

    (@fredericktownes)

    @green, I don’t know if that’s the correct setting without checking out your site, but it should be ok if your dependencies are correct.

    Hi,

    I also have the option to ‘Host minified CSS and JS files’ disabled on my installation of W3 Total Cache. I’m using Amazon S3 as my CDN. The issue I’m having is that the load time of the site has gone up massively when I first visit a particular page – it takes 11 seconds to load the minified js which is around 46K, this can’t be right can it? It’s OK when I come back to the same page on the same browser but if I hit it with a different browser, it generates a new minified js file and takes ages again.

    Cheers for any assistance!
    Kev

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: W3 Total Cache] cannot select "Host minified CSS and JS files"’ is closed to new replies.