Support » Plugin: W3 Total Cache » [Plugin: W3 Total Cache] Cannot get out of preview mode

  • Resolved Rhand

    (@rhand)


    Installed W3 Total cache. Tried to deploy, but it kept on telling me:

    Preview mode could not be disabled. Please run chmod 777 /path/to/wp-content/w3-total-cache-config-preview.php to make the configuration file write-able, then try again.

    I decided to download the file and reload it so it would be no longer CHOWN Apache Apache, but part of the group my user is in. So that I could actually CHMOD it. I chmodded it 777. That did not help. The warning just kept on popping up. I guess I will have to try a complete re-installation now?

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Frederick Townes

    (@fredericktownes)

    Probably, normally follow the installation instructions allows the plugin to do everything for you. It would be easier to start over.

    I’m having the same problem, and I’m guessing it’s a conflict with Super Cache. I think I’ve completely removed all traces of Super Cache, but I might be missing something.
    Weird thing is, I think the page cache *is* working, but minify definitely isn’t.
    Would a reinstall solve that? I’m about to find out.

    Plugin Author Frederick Townes

    (@fredericktownes)

    Did it?

    Yup, solved. But now it keeps saying .htaccess is write protected while it isn’t. That’s only relevant for enhanced page caching so not a big issue in our case. But nevertheless weird, as I’m 100% sure I’ve set the file permissions correctly.

    Plugin Author Frederick Townes

    (@fredericktownes)

    PHP can’t write to the file so the notification is shown. If there’s a bug somehow, happy to look, you can use the bug submission form from the support tab of the plugin.

    I’m having the same problem on http://www.feintandmargin.com,

    I’m stuck in preview mode despite permission on the preview file being set to 777…

    Any ideas what I could do?

    And yep, I double-checked those permissions: both config and config-preview have 777 permissions.

    Thanks Mr. Townes in advance 🙂

    same deal here. on WP 3.01

    I tried first installing via SSH then removed and tried via FTP upload.

    Same deal both time. the /path/to/wp-content/w3-total-cache-config-preview.php file shows user/group as both apache (on MediaTemple (dv) hosting). After it failed both times, I tried changing to same user/group as other plugins’ default owners but no luck.

    nb. I have memcached installed OK, other than that is standard setup

    ok, seemed to be permissions related to wp-content folder. deleted the config-preview file, 777’d wp-content, rebuillt settings file and all seems good.

    I’ve installed this on two WAMP (Windows Server 2003) servers and have the same problem on both servers.

    Any ideas how to fix on there?

    Thanks in advance 🙂

    Marky_UK

    Plugin Author Frederick Townes

    (@fredericktownes)

    Sorry I don’t use WAMP, but it’s a permissions issue on wp-content/ as @leonstafford discovered.

    Hi Frederick,

    Thanks for the reply. I’ve taken ownership of the wp-content/ folder as Administrator and it’s made no difference.

    Anyone else out there in TV land got this working on Windows?

    Marky_UK

    @leonstafford Thanks for the tip, I’ll give it a try. Unfortunately, I can’t just delete my .htaccess and have W3TC recreate it.

    Plugin Author Frederick Townes

    (@fredericktownes)

    It’s not about taking ownership, it’s about making sure that your web server (PHP) can change files.

    Hi Fredrick,
    I just installed your plugin, and generally all is well, I have the following warning at the top”

    “Preview mode is active: Changed settings will not take effect until you deploy or disable preview mode. Preview any changed settings (without deploying), or make additional changes.”

    What is preview mode? Should I deploy or disable? Do I need permissions to be at 777 before doing that? For which folders?

    Thanks, jay

    I See the following issues when running compatibility check:

    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed

    How do I get those installed? I am running WP in a shared host at GoDaddy.

    Thanks!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Plugin: W3 Total Cache] Cannot get out of preview mode’ is closed to new replies.