Support » Plugin: W3 Total Cache » [Plugin W3 Total Cache] Cannot deploy changes to settings

  • Resolved giladpn



    I appreciate the significant feature list of Total Cache. I waited for 0.9.1 since I am using WP 3.0 – but now have installed it.

    Installation went fine, and I am sure WTC is working since now I have gzip compression for example.

    However I have the following odd issue.

    After the basics, I went to the minify settings and added my CSS pages to the list as instructed (and saved). I also went to the browser cache settings and added expires headers (and saved). I then cleared all caches and pressed “deploy” as instructed.

    However these settings do not seem to take effect.
    Google PageView insists that my CSS files are not minified. insists that same CSS files have “FAILED (No max-age or expires)”.

    I tried clearing caches and deploying multiple times to no avail.

    My site is
    You can Pageview and webpagetest it if you like.
    Help appreciated!

Viewing 7 replies - 1 through 7 (of 7 total)
  • sorry typo
    the site is

    Here is the debug info for page and minify:

    <!– W3 Total Cache: Minify debug info:
    Engine: disk
    Theme: 999271
    Template: page

    <!– W3 Total Cache: Page cache debug info:
    Engine: disk (enhanced)
    Key: _index.html
    Caching: enabled
    Status: cached
    Creation Time: 0.018s
    Header info:
    Last-Modified: Fri, 23 Jul 2010 21:33:25 GMT
    Vary: Accept-Encoding, Cookie
    Etag: dcd50a37b46e43bbdf819e41a4786ea4
    Content-Encoding: gzip

    Plugin Author Frederick Townes


    I can’t guess what the problem is, this is not enough information. Please submit a bug submission form from the support tab of the plugin.

    OK submitted a bug report. Appreciate you taking the time.

    Additional info on this issue (in addition to the bug report I submitted). I did more experiments.

    It seems the issue is a bit different form what I thought at first. The basic issue is related to CSS files alone. I cannot enable neither browser-caching for CSS, nor minify for CSS.

    However browser-caching and minify for other things – do work!


    A different issue which got mixed into the one above, has to do with browser caching alone. Its as follows.

    I discovered this by enabling all features of the browser-cache (the defaults “set w3 total cache header” and “enable http (gzip) compression); plus “set expires”, “set cache control header”, “set etag”).

    This did make a difference but for the worse! reports that doing this actually REMOVED support for etags, cache contol headers, and expires headers!

    When I went back to defaults (“set w3 total cache header” and “enable http (gzip) compression”) situation improved and I am now getting etags & expires & cache control for everything except CSS files.

    So WTC does notice the changes I make for browser-caching, though whatever it does made things worse (according to


    In sum, two separate issues. I how this helps. I also already submitted the bug, as you requested.

    I had similar problems, and there seems to be a problem with the save and deploy logic.

    In order to get changes to ‘stick’ I selected only the CSS files I wanted to cache, and selected to remove comments and linefeeds, then saved changes, then immediately deployed. If I left the page without deploying and came back, it went back to no CSS files selected. I also had to do the same with Javascript files. (I tried the CSS files only first, as these don’t need much though over whether they need caching or not!). If I look at the pages with another browser, not logged in, the CSS and Javascript were minified and combined.

    (This was a new install of 0.9.1 on a site that hadn’t had any earlier versions installed)

    debugging output, just in case its useful:

    <!– W3 Total Cache: Minify debug info:
    Engine: disk
    Theme: 475696
    Template: single
    JavaScript info:
    Location | Last modified | Size | Path
    include | 2010-07-24 15:52:14 | 72194 | /home/efikim/public_html/mypicks/wp-includes/js/jquery/jquery.js
    include | 2010-02-10 12:18:20 | 4765 | /home/efikim/public_html/mypicks/wp-content/themes/k2/js/k2.functions.js
    include | 2010-07-24 15:52:14 | 8429 | /home/efikim/public_html/mypicks/wp-includes/js/jquery/jquery.form.js
    include | 2010-07-24 12:24:46 | 4594 | /home/efikim/public_html/mypicks/wp-content/plugins/contact-form-7/scripts.js
    Stylesheet info:
    Location | Last modified | Size | Path
    include | 2010-02-10 12:18:20 | 28531 | /home/efikim/public_html/mypicks/wp-content/themes/k2/style.css
    include | 2010-03-11 14:40:26 | 621 | /home/efikim/public_html/mypicks/wp-content/themes/k2e1/style.css
    include | 2010-07-24 12:24:46 | 877 | /home/efikim/public_html/mypicks/wp-content/plugins/contact-form-7/styles.css
    include | 2010-02-10 14:28:18 | 3519 | /home/efikim/public_html/mypicks/wp-content/themes/k2/styles/efikim/efikim.css

    <!– W3 Total Cache: Page cache debug info:
    Engine: disk (enhanced)
    Key: 2010/07/20/citiscape-at-sunset-by-nexus7/_index.html
    Caching: enabled
    Status: not cached
    Creation Time: 0.438s
    Header info:
    X-Powered-By: PHP/5.2.11
    Link: <;; rel=shortlink
    Content-type: text/html; charset=UTF-8
    Last-Modified: Sat, 24 Jul 2010 22:11:04 GMT
    Vary: Cookie

    Plugin Author Frederick Townes


    Have you used firebug or similar tools to check headers?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin W3 Total Cache] Cannot deploy changes to settings’ is closed to new replies.