Support » Plugins and Hacks » [Resolved] [Plugin: W3 Total Cache] Broken Visual Editor

[Resolved] [Plugin: W3 Total Cache] Broken Visual Editor

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello,

    I am the developer for “Ultimate TinyMCE”. I will download the “W3 Total Cache” later tonight and see if I can replicate the problem.

    I’ll post back here in a few hours and have an update for you.

    Have you tried “deselecting” the minify option in total cache (kinda defeats the purpose, I guess), but it would help in isolating the problem.

    – Josh


    Yes, I have. But after disabling “Object Cache” (http://screenshooter.net/3241371/fsbeubk) Ultimate TinyMCE started to work again :).

    My advanced settings of “Object Cache”: http://screenshooter.net/3241371/okfndgl

    EDIT: Strange.. When I turned off “Network Performance & Security powered by CloudFlare”, Ultimate TinyMCE disappears again. I’m refreshing page with Ctrl + F5 after changes which I made in W3 Total Cache.

    EDIT 2: Even stranger.. “Object Cache” is off and Ultimate TinyMCE dosn’t work. After deselecting Minify it’s working again.
    Object Cache: off + Minify: off = Ultimate TinyMCE works.

    I also am experiencing the problem.

    Clicking on visual didn’t work. Clicking to insert a graphic appeared to work but nothing showed up in the edit box. I was able to type in text but it disappeared when I tried to save.

    The tech at the host erased the folders for all plugins. It was still broken. He discovered that going to user and disabling the visual editor permitted using the HTML editing. That is where I am now and I’m lousy at HTML.


    It also sounds like a plugin conflict. You shouldn’t have to disable the visual editor, though.

    So even with the plugin deleted, you still cannot access the visual tab in your editor?

    The plugin was not only deleted but the host deleted all of the plugin folders and I updated WordPress to the latest version.

    I would think that might clear it up, however someone on my theme’s support forum said he was always wary of new plugins because some wrote to the database. He wasn’t able to go further because of his lack of familiarity with SQL. I might need to look for someone adept at SQL. There seems to be few options remaining.

    That’s true, a lot do write to the database. But most of the best, highly developed, plugins will write to the database… so you would be missing a lot by only using this criteria.

    However, very few plugins are malicious (as far as I’ve seen). It is true that some can cause issues with your theme, installation, or database. That’s why it’s always important to backup before “trying” a new plugin.

    Here are a few considerations when looking at new plugins:
    1. What is it’s rating?
    2. How many downloads does it have?
    3. How many say it works vs broken?
    4. Is there a support forum or area for help with the plugin?
    5. Is the plugin author responsive (like we are doing here)?

    If you would like me to take a closer look at your installation, let me know and I’ll provide you with a way to contact me securely with your login info.

    – Josh

    I appreciate the offer and would like to take advantage of it.

    Okay.. you can use my contact form on my personal site here:

    Send me an admin level username and password. I’ll take a quick look at the admin panel and see if I can find anything “funny”.

    Oh, and include your site url.

    Thanks for the help. the problem is solved.


    another problem: http://screenshooter.net/6170927/lhpsinn

    I think this is problem with insufficient amount of RAM. Josh, maybe plugin can throw some exception about it?

    – Leszek.ee

    Is it that your buttons are disappearing? This is most likely a plugin conflict with another plugin trying to add a button to the tinymce editor.

    Try temporarily disabling your other plugins… and check back on your post/page. Let me know if it works when you deactivate your other plugins.

    I have a similar problem: with W3TotalCache the plugin seems not working. Any news about this incompatibility?
    Kind regards.

    How is it not working? Can you give me some specific details?


    I am having the same problem, how ever my conflict seems to be with E-Newsletter from WPMU DEV.

    Hi Josh,
    I have been having this problem for quite a while(months?) and I do not have any of those plugins active/installed. I noticed the first time it occurred was with my newsletter plugin; when editing the text that the user would receive in their email or onsite, I would only have access to the html portion of the editor. The visual editor tab is there, but clicking on it does nothing. However, when I would change any setting in UTmce and save the settings, my visual editor would be available again!? I haven’t thought too much about it as I’ve not been able to work on the site for a while.
    Tonight though, I was backing up my UTMce buttons and decided I wanted to change some things about my signature. It is currently only allowing me to work with the html side of the editor, so I cannot do much. I have not been able to change this, even after deactivating my other plugins etc. However, I tried changing a random setting and now, the Visual Editor is back with all of its Ultimate TinyMCE goodness intact?!
    I believe that this problem started after an UTMce upgrade, but I don’t remember which. =( It definitely seems to be something that is defunct with UTMce to me…
    I finally decided to come on the forum tonight and see if anyone else was having this problem – I see there are some, but I’m not seeing a “fix” for it. Modifying which plugins are installed/activated has never been a solution for this issue on my end, so I hope you’ll have a direction to go in other than this….
    ~ freida

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] [Plugin: W3 Total Cache] Broken Visual Editor’ is closed to new replies.