WordPress.org

Support

Support » Plugins and Hacks » [Plugin: W3 Total Cache] Breaks Feedburner Polling

[Plugin: W3 Total Cache] Breaks Feedburner Polling

  • Hi:

    I installed W3 Total Cache just recently and went from having my feed updated in Google Reader and in Twitter (pulled using Feedburner) in a matter of seconds to it not pulling at all. It is my understanding that this might be due to Minify so in the interest of getting W3 Total Cache working and getting my feed updated, I disabled HTML minify. Alas, no luck. The manual ping via Feedburner seemed to work after disabling minify, however the automatic pull didn’t work as it was before installing the plugin.

    Any ideas?

    Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Try disabling feed caching on the page cache settings tab. There is no known issue with this case, so they’re could be an issue with a feed related plugin here if you’ve already disabled minify.

    I had the same problem – Frederick’s suggestion of disabling feed caching fixed it for me. Thanks very much.

    Can either of you guys submit a bug submission report so I can see what’s going on here? I cannot duplicate this regardless of settings.

    I just wanted to chime in and say I was having this exact problem, but Frederick’s solution worked wonders. Feedburner was over two hours behind on my most recent posts, however after I unchecked the feed cache setting, it caught up on all of my posts within seconds.

    Glad to hear it. Not sure when some have this problem and others not. I also see cases where pubsubhubhub plugin works for some and not others.

    Hi Frederick, I installed W3 a few days ago and feedburner is not updating, even after a manual ping and a nuclear resync of the feed in feedburner.

    I tried disabling the feed caching (5 minutes ago) and nothing. Do I have to clear the cache too? Thx in advance.

    Also, I tried turning off Minify and manually pinging again – nothing.

    I’m hesitant to empty the cache unless that is the fix for sure as I’m getting a bit of a traffic spike (for me anyways) and I don’t want the server to crash…

    Resolved – my feed was over 512K – reduced the size by apending

    ?max-results=#

    Where # is the number of feeds that show up in the feed. Support suggests a max of 500, but even 50 should be fine.

    Glad you figured that out preetbanerjee.

    Same problem here. It looks like limiting the number of feed item as preetbanerjee suggests, fixes the problem.
    However I’m getting an error on minified feed XML output…
    Frederick, if possible I would send you a link to the offending feed…

    Well are we talking about the feedburner limit here or not?

    Same problem feedburner hasn’t touched mine since installed…

    I just submitted bug report… Let me know if you need anything.

    For now the option to cache feeds on the page cache settings tab needs to be disabled if you’re having this issue.

    Just wanted to jump on here and say that I have two sites, same hosting, one a subdomain of the other – both are using Total Cache and FeedBurner, but one has experienced this problem while the other has not.

    I’ve disabled feed caching for the moment and it’s returned to normal, although some amount of caching would be desirable!

    One other thing I’d mention – the site that had the issue with feed caching also had a bizarre issue with using the APC opcode options – using that option stopped pages from loading. Again, the other site appears to be just fine. Don’t know if it’s related, but I thought I’d mention it just the same.

    Frederick Townes

    @fredericktownes

    @gerrybot, do both of your sites have the same traffic levels and the same page caching settings?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: W3 Total Cache] Breaks Feedburner Polling’ is closed to new replies.
Skip to toolbar