W3 Total Cache
[resolved] Blank wp-admin/index.php page when W3TC is active (12 posts)

  1. cruiseback
    Posted 5 years ago #

    Hey all,

    I have just finished setting up a WP site with W3 TC.

    When the plugin is active the wp-admin/index.php page becomes blank.

    I have tried enabling/disabling all plugins, and the problem seems to be with this one.

    When I put define('WP_DEBUG', TRUE); in wp-config.php, wp-admin/index.php spits out:

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /domains/www.steenkofoed.dk/www/wp-includes/functions.php on line 3323
    Notice: Undefined index: general in /domains/www.steenkofoed.dk/www/wp-content/plugins/mailpress/mp-includes/class/MP_Log.class.php on line 36

    Maybe the host is running some old version of PHP, I'm not sure, but is there some way this can be fixed?

    I have been Googling for a solution but so far no luck.

    Thanks, cb

  2. cruiseback
    Posted 5 years ago #

    The PHP version on the host by the way is PHP Version 5.2.1-0.dotdeb.1

  3. Jochen Haeberle
    Posted 5 years ago #

    I have this behaviour as well. It seems to me that changing some admin-stuff like updating plugins starts this. Either directly or after cliking empty cache. After that admin- and content-pages become totally blank. Only a restart of apache resolves this.

    This is from the compatibility check of the plugin:

    Compatibility Test
    Server Modules & Resources:
    PHP Version: 5.2.6-1+lenny8
    PHP Timezone: Not set
    Web Server: Apache
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: APC
    Memcache extension: Not installed
    Mime type detection: Mimetype
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    mod_mime: OK
    mod_expires: Not installed
    mod_deflate / mod_gzip: Not installed
    mod_headers: OK
    mod_env: OK
    mod_setenvif: OK
    mod_rewrite: OK
    WordPress Resources
    /some-path/wp-content: Write-able
    /some-path/.htaccess Write-able
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off



  4. Jochen Haeberle
    Posted 5 years ago #

    BTW: I am on WordPress 2.9.2 still :-(

  5. Frederick Townes
    Plugin Author

    Posted 5 years ago #

    Can anyone with this issue email me? So far I have not enough information to take any action.

  6. Jochen Haeberle
    Posted 5 years ago #

    Hi, contacted you thorugh PI bug request form - I found no other easy/obvious way.

    I upgraded to WP 3.0.1 today but had the issue again.


  7. Frederick Townes
    Plugin Author

    Posted 5 years ago #

    This typically occurs when another plugin interferes with W3TC. Are you able to disable other plugins and activate them one-at-a-time until one fails to activate?

  8. rickjanusz
    Posted 5 years ago #

    It's the setting under Micellaneous in the Performance tab of the admin panel, get there by going here after logging in:
    (this will work even after getting the blank dashboard page)


    Enable dashboard news widget

    That should fix it!!!!!

  9. Jochen Haeberle
    Posted 5 years ago #

    sounds pretty interesting... that is defenitely not anything I tried before ;-)

    I will give it a try and tell what happened in a few days.

    Thanks for the tip!

  10. rolandvparidon
    Posted 5 years ago #

    Thanks rickjanusz, for your awnser. This fixed it for me aswell. I got this error after installing another plugin. Almost every plugin, even yoast google analytics.

  11. colter
    Posted 5 years ago #

    rickjanusz, good job, a simple disabling of the news reference in settings works perfectly.

  12. Frederick Townes
    Plugin Author

    Posted 5 years ago #

    Sorry for the trouble, will check the issue related to the widget.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic