Support » Plugins and Hacks » [Plugin: W3 Total Cache] Amazon Cloudfront CDN not working.

[Plugin: W3 Total Cache] Amazon Cloudfront CDN not working.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’ve tried reinstalling the plugin, no help 🙁

    I’ve reverted it back to w3-total-cache. with no help.

    Fixed. Apparently, I put some useragent in the bypass list for CDN, and it practically wiped out everybody.

    Could you please elaborate how you’d fixed it? I’m trying to configure W3TC for CDN but am finding that nothing is being served by the CDN. Had contacted MaxCDN customer support and the lady has confirmed that “w3 total-cache and CDN is already well-implemented” but I see nothing being served by CDN when I log on Pingdom.

    First, make sure your CDN is up and running. While in panic mode, I messed around with mine and inadvertently changed a setting, which caused it to be in “In progress” status instead of “Ready”.

    You can do a test by going into your wp-admin >> Performance >> CDN >> Configuration >> Test.

    Once the test passes, go back to Performance >> General settings >> Debug >> tick the “Content Delivery Network” box >> save.

    When I turned mine on, I looked at the source code on the frontend (you have to do this on a different browser where you’re not logged in), and saw that CDN was rejected by user agent.

    Go to Performance >> CDN >> “Rejected user agents:” >> make sure it doesn’t block anything funky. I wiped that list out and it started working for me.

    I remember putting Google crawler’s user agent onto that list, but I’m not sure what else I had on there that made it not work. Again, while in panic mode, I cleared the list and things were back to the way they were.

    Hope that helps.

    Thank you! Have nothing on the rejected user agent list but the debugging is a very good idea- will try that.

    The CDN provider is telling me it’s because of Cloud Flare, which is strange given the write-ups on combining Cloud Flare and a CDN. I think it could be the way I’d configured caching from Cloud Flare…

    Plugin Author Frederick Townes


    Did you get to the bottom of the issue?

    Hi Frederick,

    The problem seemed to be the separate Gzip plugin. Turning that off seemed to solve the problem. Didn’t like having the Gzip plugin turned off though so will only stick with Cloud Flare for the moment.

    Plugin Author Frederick Townes


    Aha, glad you sorted it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: W3 Total Cache] Amazon Cloudfront CDN not working.’ is closed to new replies.