Support » Developing with WordPress » [Plugin: W3 Total Cache] A complicated mess

  • Resolved KimJCastleberry


    I’m pretty sure Frederick isn’t going to like me for this mess! LOL!

    I’m pretty sure this is a site issue not a w3tc issue but I don’t know where to start.

    My site has always been extensively resource heavy, to a extreme degree, even after having been looked at closely by four of the core dev team at Savannah WordCamp.

    We moved it to a virtual machine, using memcached, to isolate it because it crashes just about everything else. W3TC has become a plugin I absolutely depend on to keep the site up even “most” of the time.

    I’m an extensive beta tester and somewhere between 3.0 and 3.1 stable, I picked up a “minor” problem that I became aware of after rolling on to 3.1 stable, that of missing the pagination for the page in wordpress that lists all posts. (In the middle of that beta I also lost the ability to write php errors only to log and not to screen, in the manner I had been doing for many versions, and we’ve since had to try to come up with other workarounds, but no one on the beta list seemed to know what I was talking about.)

    Deactivating all plugins (except maintenance mode) and rolling the theme to Twenty Ten or Eleven does not fix this.

    About this time site stability took a small turn for the worst, but I was struggling with some family stuff and did not hat time to debug.

    A couple weeks back (actually closer to a month now), one of the upgrades to w3tc started interacting with something my site is doing and caching all the wrong stuff.

    Also at the same time, my cloudflare + maxCDN settings started conflicting and suddenly if I had them both enabled, the site flat out wouldn’t load front end. This happened immediately after a w3tc upgrade but I’m sure from reading notes from maxcdn that I didn’t have this 100% set up right in the first place. I was able to get to the backend but not the front end, and I disabled maxcdn at the time (unfortunately).

    Regarding the prior paragraph about incorrect caching, if I went in to write a new post, in the new post editor. It might cache the page at the first sentence, and when I hit save draft, the draft save would be the cached copy, not the now several paragraphs I’d wrote. I started disabling w3tc every time I wanted to write a post. Writing, publishing and then re-enabling.

    I know I should have been in here looking for help then. It was also caching plugin upgrades and would cache somewhere after the upgrade but before the activation, so that even though the upgrade progress said the plugin was reactivated, once I cleared the cache, it was obvious the newly upgraded plugin was not activated and I needed to activate it manually. This gets old after a while.

    There’s other admin related pages being cached too but those are the biggest ones.

    Today I found myself getting a 500 error only on wp-admin/post-new.php and chased that back to “Yet Another Related Post Plugin” which I just deactivated.

    Theme is a css-changes-only child theme to twenty eleven.

    Current active plugins are:
    All-in-one Webmaster
    Auto Excerpt
    Commentluv Premium
    Digg digg
    Google xml sitemaps
    PrettyLink Pro
    Social (by Mailchimp)
    TinyMCE Advanced
    WordPress SEO (by Yoast)
    WP Subscribers

    Recently (and usually) active: Premium Slider, SEOPressor v4, YARPP & W3TC.

    I’d be happy to provide a w3tc settings export (or site access) though I don’t want to link to that settings export here since it contains my cloudflare api key etc.

    Even after removing YARRP today, reactivating w3tc still presents me with caching trouble in post edit page, and makes it nearly impossible to compose a post without deactivating it.

    I’m uncertain if the pagination issue on wp-admin/edit.php is a big deal or inconsequential but I felt it necessary to include to paint the big picture.

    Any feedback, thoughts, or advice?


    PS: If I’m slow replying back its because I have to leave my main browser to reply. Firefox has picked up an annoying tendency to auto-case-correct my username for the forum (I hear others are having this issue with other sites) and because the UID here is case sensitive I have to log a different browser just to reply.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Kimberly,

    Wow sounds like you have a big problem on your hands here. It also seems like there could be several different issues going on here as well.

    1. Database related issues seem highly likely. Almost as if an update didn’t take right. I would be sure to optimize and repair your database using PHPMyAdmin or the MySQL command line tool set. Install WPDBManager would allow you to run this process as well. I would be sure to take a backup of your database first just in case.

    2. What is your current server setup? You can PM me or email if you prefer. I wouldn’t want you to post your server setup on the WWW. But it seems like your server needs to be optimized for your site. Every site is different and the server should be optimized to run your site specifically.

    3. Given the fact you are having issues with the admin panel it seems like you might have some files that were not updated properly or other problems. I would double check your file permissions on the entire site files and then consider re-installing Word Press. It seems highly unlikely that W3 Total Cache would be causing issues here, but I guess it is possible.

    4. YARPP and SEOPressor are two plugins that are MAJORLY resource intensive. There is a setting you can disable for YARPP, I believe it is consideration of Tags. That should speed YARPP up CONSIDERABLY. I don’t think there is anything that can be done to speed up SEOPressor, but I am probably wrong. I don’t have much experience with it besides telling people to disable it. (I previously worked at a major hosting company on the team that was responsible for disabling and re-approving sites that were using too many resources on the shared (and VPS) servers).

    5. I would recommend checking out Gregs High Performance SEO Plugin as well. It is another plugin that can help speed up your site.

    I would be glad to talk to you more about the CDN issues and such but that is a much more complicated subject especially given the fact you are using two different CDNs.

    Best of luck to you and if you want to take this off-forum for more detailed analysis I am glad to help you out.



    The post edit admin pagination issue is still chasing me after a ton of work.

    Seems I’m not the only one ->

    So I started with a full database cleanup, repair and optimize. Beyond reducing my db size due to removing a ton of revisions, this didn’t do anything for the pagination issue.

    As I mentioned above, switching themes and deactivating plugins also still was not helping.

    So I finally made time yesterday to back up my database, export my xml, install (build) a totally fresh database, upload my xml (rather than doing a database import) so that the db remained clean… and reinstall plugins. I also switched back to my original theme that I haven’t run in months and was really missing.

    The problem reappeared somewhere along the way.

    Just like prior, deactivating plugins or switching to TwentyTen doesn’t give me the pagination and makes accessing old posts to edit hard.

    The link I shared above has some info on someone else’s site doing it and reports of a blank array but not enough info I can tweak anything.

    Current Theme: Thesis 1.8.2

    Plugin list currently:
    All-in-One Webmaster, Commentluv Premium, Configurable Tag Cloud, Digg Digg (inactive), Google XML Sitemaps, Jetpack by (inactive), Maintenance Mode (inactive), Premium Slider, Pretty Link Pro, ReplyMe, RSS Link Bomber, Social (inactive), TinyMCE Advanced, W3 Total Cache (inactive), WPSubscribers

    The screenshot is the same as I linked too in my original post, the pagination is simply missing.

    I’m scratching my head…

    Thinned that plugin list down to:

    Commentluv Premium, Configurable Tag Cloud, Google XML Sitemaps, Premium Slider, Pretty Link Pro, ReplyMe, TinyMCE Advanced, WPSubscribers

    That leaves 8 in total. Deleted all others so no code was lurking about.

    Should also be noted that at the same time I did the database optimization, that I replaced the code base. So all of the core files except wp-content, wp-config and htaccess and php.ini were replaced already.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What theme are you using? It’s possible a weird settign in the functions file could do this.

    Have you tried the developer tools, either in FF or Chrome, to look at the code and try to find what’s causing the pagination to disappear? You should be able to find any Javascript errors, or strange CSS happenings.

    I have fixed this problem! The fix:

    Disable mysql.trace_mode in php.ini


    I appreciate the followup by Fylh. That is the same conclusion we finally arrived at at approximately the same time.

    Unlike you disabling it from the php.ini we disabled it at the server level as it was not needed for other processes on that dedicated/VM.

    I’m uncertain if we prior enabled this for debugging purposes or if it was a artifact of an older version of php. Because I acquired the issue near the 3.0 beta, I assume it is somehow linked to the change over in php requirements that happened in that same time-window.

    We arrived at this by looking at the other thread I linked too, analyzing the code and realizing the query was a non-standard mysql query. This non standard query has some issues with that particular php tool and freaks out. Oddly if you replace it with the native mysql command it doesn’t freak out… but that involves altering core code so was not really an option for me.

    Disabling that command completely restored the pagination issue.

    Thank you for everyone that assisted publicly and privately in helping debug this. It was a heck of a mess LOL!

    I do not have the problem, but I am using php 5.2.17 and php 5.3.8, I have a few sits on two servers.

    I like to disable all plugins before activating w3 total cache.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: W3 Total Cache] A complicated mess’ is closed to new replies.