WordPress.org

Support

Support » Plugins and Hacks » [Plugin: W3 Total Cache] 500 Internal Server Error

[Plugin: W3 Total Cache] 500 Internal Server Error

  • Frederick first I love your work and thanks for what you do for the community. I have been attempting to install the latest release of W3TC with wordpress 3. In doing so after activation I receive the:

    You’ve selected disk caching with enhanced mode however the .htaccess file is not properly configured. Please run chmod 777 /home/waves8/public_html/.htaccess, then . To manually modify your server configuration for enhanced mode append the following code:

    I have changed the .htaccess and attempted the retry. You code gets inserted into the .htaccess then I get:

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@wavesoftech.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.wavesoftech.com Port 80

    The site is then totally down and I have to remove the W3TC code from the .htaccess file. Any assistance would be appreciated.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 16 through 30 (of 39 total)
  • Thanks.

    Thanks Frederick for addressing this issue for us.. muchly appreciated!

    No problem, I would love to avoid these issues if I could, but there are limitations unfortunately.

    3 weeks to the day and STILL the same problem! Crashed my site…”thanks”.
    You seriously need to address this because the problem is persisting. Going back to the cache plugins I was using with ZERO problems.

    I am new to W3 Total Cache. I wanted to use it because of its great reviews. But on activation of the plug-in, I got the 500 error. I had to manually remove all the files and clean out the htaccess to get things working again. Is there an end to this 500 bug in sight? W3 sounds like a super cache solution, and I’d love to use it.

    There will be no end if users don’t allow me to investigate the origin of their issue. You can contact me through my web site if you would like to constructively contribute.

    Over the past year there are lots of reasons for lots of errors, it’s not as if the same issue has existed indefinitely.

    At the moment, the issue is caused by users who have move their web site and the WordPress database has the WRONG value for the path to the uploads directory. So you can go to the misc’ section in WP Admin and change the uploads value to anything other than it’s current setting and save. Then restore the previous value and save the settings again. Then try to follow the installation instructions again for W3 Total Cache. This issue was difficult to find as it doesn’t affect everyone and there’s no error message or anything in error logs when users experience it.

    A workaround for that is coming in the next release.

    I just installed it and as soon as I clicked “activate”, my entire site started getting 500 internal server error. Too bad since I have this plugin on another site and love it. Hope the next release with a fix comes soon.

    @blueicreate, that comment doesn’t help me make sure there will be a fix. Did you compare your .htaccess files on your sites to see what the differences were? Did you check your error log? Could you actually help please?

    I had this problem but found a work around that some of you might want to try.

    I built a site locally then switched to a hosted environment. If you have FTP access to your site then try downloading the plugin to your computer, unpack it, then upload it to your plugins folder. I didn’t have to touch a line of code after that.

    While this solution worked for me it still might not with other users.

    BTW, Frederick; you guys rock on the WordPress Podcast. I learn so much just listening. Keep up the good work.

    [UPDATE]- Ok, so it didn’t work for me. Don’t try this. It’s all about learning new things right guys and gals? Sorry for screwing anybody up.

    Hi Frederick. I also had the “activate causing 500 Internal Errors” issue. It took me several minutes of panicked frenzy to figure out that the .htaccess file was probably at the root of the issue. I would have loved to give you a comparison, but I was so flustered with a failed site that I just restored the file from a backup. Only afterwards did I wonder what was going on.

    I would have provided an error log excerpt but, for me, there were no errors being generated in a place where I could see them. My hosting service gives me an access log and a CGI error log, but nothing was being put into that CGI error log. While I’m sure there were errors being generated I didn’t see them (other than on the browser) and I’m not sure I can see them.

    Now that I know what’s going on, I’m willing to reinstall the plugin (over the weekend when things are quiet) and attempt to figure out what is happening. If there is any additional information you need (apache version, etc.) that would be of use please let me know.

    Hi There –

    Can somebody walk me through a manual removal of the files to restore my blog after the “500 error”? I thought I removed all the files associated with W3 and I restored my .htaccess file and yet my blog is still down. I am more than a little freaked out right now….

    Thanks!

    If you’ve restored your .htaccess file to the state before the installation, then this post is what you need: http://wordpress.org/support/topic/plugin-w3-total-cache-500-internal-server-error?replies=27#post-1612692

    Hi Fredrick, love your plugin!

    I have installed your plug-n on over 6 of my sites all of which are Hosted with the same host company. However, with my latest site (also with the same Host) the minute i Activated the Plug-In the site disappear into Error 500. Now, we know already that it has to do with the .htaccess re-writes, however after spending the day with my Host Company support they couldn’t figure it out.

    For some reason once the Plugin is activated it generates the following code which creates the Error 500:

    <FilesMatch "\.(?i:css|js)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.1.1"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(?i:html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.1.1"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(?i:asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|swf|tar|tif|tiff|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.1.1"
    </IfModule>
    </FilesMatch>
    
    Full source of .htaccess file which causes 500 error message you may see with name .htaccess_ in your estheticclinique.co.uk domain.
    Also let me inform you that FilesMatch directive works perfectly at your server. You may check it using the following example:
    
    <FilesMatch "\.(htm|html|css|js|php)$">
    AddDefaultCharset UTF-8
    DefaultLanguage en-US
    </FilesMatch>

    `
    It would be great to get some direction as to how do i go about sorting this out.

    many thanks.

    D.

    If you go to miscellaneous settings and change the uploads path to any other setting, save the settings, then revert the setting to the previous value and save the settings again you should be able to activate. If not, let me know.

    Hi Fredrick, sorry for the misunderstanding here, do you mean the WP Media upload path? i.e. changing the default “wp-content/uploads” to another path and then Deactivate/Activate the W3Total Cache and reverting the wp-content/uploads?

    or something else?

    i want to get it right.

    thanks.

Viewing 15 replies - 16 through 30 (of 39 total)
  • The topic ‘[Plugin: W3 Total Cache] 500 Internal Server Error’ is closed to new replies.
Skip to toolbar