W3 Total Cache
[resolved] still BAD -> FTP details (48 posts)

  1. frg
    Posted 5 years ago #


    when minified, JS and CSS return "Bad file param format"

    With FTP I had a look into the minify directory

    There are two files:

    default.include.css.id containing i:615365546;
    default.include-body.js.id containing i:2138336412;

    nothing more..

    In the last good version there were six files:

    default.include.615365546.css 21kByte
    default.include.615365546.css.gzip 5kByte
    default.include.css.id containing 615365546
    default.include-body.591478768.js 113kByte
    default.include-body.591478768.js.gzip 45kByte
    default.include-body.js.id containing 591478768

    So the combined/gzipped versions were never produced. Hmm.

  2. WebEndev
    Posted 5 years ago #

    Yep. THIS is the problem exactly.
    Hopefully the plugin author is seeing all of these posts and working on a solution...

  3. frg
    Posted 5 years ago #

    With switched on CSS minify I tried copying the three "good old" css files in place.

    ..just to find out "default.include.css.id" containing "615365546" gets overwritten by default.include.css.id containing "i:615365546;"

    maybe this info helps further..

  4. copysmith
    Posted 5 years ago #

    That's the problem I experienced as well. I've disabled the plugin until this can get resolved. Curiously, it works fine in the latest version of Firefox, but not in IE.

  5. frg
    Posted 5 years ago #

    but maybe you are logged in admin in firefox? Then in FF you will get the un-minified <working> version..

  6. copysmith
    Posted 5 years ago #

    You're right. I logged out of admin and FF also doesn't work.

    Anxiously awaiting a fix...

  7. frg
    Posted 5 years ago #

    Waiting, yes - me too :(

    no minify sounds like a minor problem, but my page doubled in size & has some extra files to serve:


    We will see.
    Our gifted author will find a solution - I got the feeling there is a typo somewhere. Have to stop searching, worst case I will deinstall & downgrade.

  8. sebastien.barre
    Posted 5 years ago #

    Yup, same here with Bad file format, even in manual mode.

  9. rpetersnmt
    Posted 5 years ago #

    Ditto here on a couple of sites that I recently updated to in advance to anyone working on a solution.

  10. boborg
    Posted 5 years ago #

    Yes same problem here.

  11. katzenback
    Posted 5 years ago #

    Until they get this fixed, the best bet is to uninstall the current version and install the latest working version from http://wordpress.org/extend/plugins/w3-total-cache/download/

    You should not use version or - wait for a new update that fixes the issues.

    If you did update your plugin and you need need uninstall the
    previous version. You will need to go into your blogs htaccess
    file and remove all the content from...

    # BEGIN W3TC Skip 404 error handling by WordPress for static files


    # END W3TC Page Cache

    Make sure you save a backup copy of this htaccess file. Then
    when you activate the older version the htaccess file
    will be updated.

  12. Ballet News
    Posted 5 years ago #

    I have the same problem. http://www.balletnews.co.uk In IE8 it works for me fine, but not the other browsers.

    I contacted the plugin owners and have neard nothing.

    I'm not technical and would like to get back to the older version. Is it possible for someone to let me have step by step instructions for a non technical person please, since I don't understand any of the coding.

    thank you

  13. Gilligan
    Posted 5 years ago #

    Same issue here. Problems with multiple sites!!!

  14. robnalexpress
    Posted 5 years ago #

    @Ballet News- Your site is not right in IE8 either. You're probably just logged-in to WordPress Admin in IE8 or viewing a cached page. Have you switched minify mode to manual and cleared all caches in W3TC? That should do the trick. I have 3 sites running the latest version with no problems as long as I keep minify mode set to manual.

  15. frg
    Posted 5 years ago #

    @ robnalexpress

    ok, you switched minify to manual, but did you then add some files..
    that´s where the trouble starts for the rest of us.

    the error boils down to no gzip but minify working, if you switch in "Browser Cache" js/css gzip OFF..

  16. sysopsavant
    Posted 5 years ago #

    I have two sites setup with this plugin. the first one is:

    The second is:

    Both are on the same Hostgator server. I've had the plugin installed on the first domain for quite some time. It is set to manual currently and only had a few scripts manually selected originally. Now it lists no scripts selected and doesn't seem to be causing any issues.

    The poppameth website is set to auto and gives me this error:

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    I haven't noticed any problems with the site though, even when logged out and in different browsers. Is this only occurring when set to manual and files are actually added?

    Edit: I disabled GZIP and the error message disappears.

  17. robnalexpress
    Posted 5 years ago #

    @frg- I get your point, but can't you (at least until this is fixed) just remove those files from your server?

  18. frg
    Posted 5 years ago #

    @ robnalexpress

    yes - i can get a running site with no files in the minify lists, css & js not gzipped (.. or only partly - dunno why).

    but i decided for to have the listed files minified & combined and can live with css & js not gzipped.

    tried both options for me the second is faster (testet with webpagetest.com).

  19. frg
    Posted 5 years ago #

    just found.

    for the technical minded (& fit in german) here seems to be the perfect fix:


    i ll try it as soon as i have more time - dont want to break my baby :)

  20. Cedric
    Posted 5 years ago #

    Damned, I don't catch a word from german!

    I will wait for the next update of the plugin...

  21. Ballet News
    Posted 5 years ago #

    thanks everyone. I have minify on manual - but still nothing seems to have improved....

  22. Arundel69
    Posted 5 years ago #

    @frg, that solution is simply fantastic! It fixed everything for me as well. There is an incredible amount of tiny, but fundamental, changes to be done... hopefully, "M. Nieberg", the author of that excellent article, is able to write something equivalent in English and send it to the W3TC developers; some of those fixes are really crucial.

  23. sysopsavant
    Posted 5 years ago #

    If it helps anyone you can use the Google translate page to view it in passable English.

    See if this works.

  24. frg
    Posted 5 years ago #


    glad to hear that!

  25. kw2
    Posted 5 years ago #

    I've created an english version of this article
    google translate also translates the code. The link was also send to the developers. Perhaps it helps to make things better.

  26. frg
    Posted 5 years ago #

    it works!
    it works!

    Howto correct Minify&Gzip-errors with W3Total Cache W3TC
    (based on M. Nieberg´s

    *** make backups of:
    *** edit wp-content/plugins/w3-total-cache/lib/Minify/Minify/Controller/Base.php
    change  ,'encodeMethod' => 'zero'
    to      ,'encodeMethod' => 'gzip'   //MN: Was 'zero', set to gzip

    *** set in admin Performance->Minify->General: Rewrite URL structure ON

    *** set in admin Performance->Browser Cache->Cascading Style Sheets & JavaScript: Enable HTTP (gzip) compression ON
     (this updates to your root/.htaccess)
    *** edit wp-content/w3tc/min/.htaccess:
    (in "W3TC Minify core" part)
    change  RewriteRule ^w3tc_rewrite_test$ index.php?w3tc_rewrite_test=1 [L]
    to      RewriteRule ^w3tc_rewrite_test$ index.php?w3tc_rewrite_test=1 [QSA,L]
    add     ReWriteCond %{REQUEST_FILENAME} !^.+\.gzip$
    after   RewriteCond %{HTTP:Accept-Encoding} gzip 
    change  RewriteRule (.*) $1%{ENV:APPEND_EXT} [L]
    to      RewriteRule (.*) $1%{ENV:APPEND_EXT} [QSA,L]
    change  RewriteRule (.*) index.php?file=$1 [L]
    to      RewriteRule (.*) index.php?file=$1 [QSA,L]
    *** edit root/.htaccess:
    remove a lot (60?) of linefeds which W3TC put.
    (in "W3TC Page Cache core" part)
    change  RewriteRule ^(.*\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [L]
    to      RewriteRule ^(.*\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [QSA,L]
    ("BLOGSUB/" is the name of your WP subdirectory, is missing if installed in root)
    RewriteRule .* "/BLOGSUB/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    RewriteRule .* "/BLOGSUB/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [QSA,L]
    *** make both .htaccess files writeprotected by ftp:
    delete the write flags
    (doesnt work for me - i only get it down to 644 not 444)
    after i look in admin Performance, i got the two fleshy bars:
    Disk enhanced page caching is not active..auto install
    Minify is not active..auto install
    .. but i ignore them because my site works!
    minify & gzip is ok now!
    i know the changes will be overwritten if i change my W3TC settings again.
  27. frg
    Posted 5 years ago #


    Vielen, vielen Dank! Super!

  28. sysopsavant
    Posted 5 years ago #

    This is weird. I just switched the http://www.morrispaint.com website that was working fine to automatic minify settings and left gzip enabled. No errors have occurred that I can tell. The only difference I can tell is that the morrispaint domain is in the root of the public folder and the poppameth domain is in a sub-folder as an add-on domain.

  29. frg
    Posted 5 years ago #


    but it looks NOT highly optimized 75/100 score


    also here only 75/100 score

    are you shure minify is on & properly configured?

  30. sysopsavant
    Posted 5 years ago #

    It's on but I'm not sure it's properly configured. I haven't been through all the new settings yet since the upgrade. Looks like the add-on domain is causing some issues there too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic