WordPress.org

Support

Support » Plugins and Hacks » vSlider Multi Image Slider for WordPress » [Resolved] [Plugin: vSlider Multi Image Slider for WordPress] Fatal Error after updating to vSlider 4.2

[Resolved] [Plugin: vSlider Multi Image Slider for WordPress] Fatal Error after updating to vSlider 4.2

  • Help! – a client’s site has suddenly come down with a fatal error after I just updated to vSlider 4.2

    Fatal error: Call to a member function generate_theme() on a non-object in /[…directory path]/public_html/wp-content/plugins/vslider/vslider.php on line 59

    (The “[…directory path]” was substituted in this message as it contains the WP username)

    In the meantime, I will try to re-install the plugin. I have very little PHP knowledge to troubleshoot the error.

    I hope some knowledgeable kind soul knows what the problem is and can offer some suggestions. I’ve placed the site into “Maintenance Mode” for the time being.

    http://wordpress.org/extend/plugins/vslider/

Viewing 15 replies - 1 through 15 (of 23 total)
  • More information: When I go to the vSlider settings in the left sidebar, I just see a button saying “Upgrade to vSlider 4.2”

    Perhaps the regular update didn’t complete properly?

    At any rate, clicking on the button doesn’t do anything.

    Update: I’ve tried deactivating it, then activating it again, and was given an option to “Migrate to 4.2” which I did.

    The website now loads up without showing errors, but the slides are blank.

    The data appears to be in the settings, but right now, I’m trying to figure out how to get the slides to display again…

    Previously, there was an option to Activate or Deactivate a particular slider. Is there an equivalent option in this version? I’m having difficulty finding it.

    I am having the same problem! My images are also not appearing within the slides, where they did on the previous version of vSlider…

    http://nwimt.com

    The big blue space should be a featured post image slider!

    Hi Ashley, I see one big image there. Is it meant to show more or are you still trying to tweak it?

    Right now, I’m attempting to delete the whole plugin and re-install the older version 4.1.1 which worked a bit, but not displaying the slides properly!

    Same problem here. Thankfully, was able to roll back to previous version.

    Plugin Author Mr. Vibe

    @wpthemes

    Please deactivate and reactivate the plugin. It should resolve these issues.

    Plugin Author Mr. Vibe

    @wpthemes

    http://nwimt.com : The vslider haven;t migrated properly, please deactivate and reactivate your plugin from Dashboard->plugins panel

    Deactivate and reactivate is not working for me. Other workaround?

    I managed to re-install 4.1.1 and set it all up again.

    I’ll stick to this for a while and see what happens with 4.2.

    Otherwise, I think it’s a great plugin and I’m really grateful to Mr. Vibe not only for writing it but taking time out to respond to support requests.

    Thank you very much!

    Plugin Author Mr. Vibe

    @wpthemes

    I checked again, the vslider on your site is using older files. the site is using older vslider.js file. So you’ll have to deactivate and delete and then install and activate the plugin.

    Plugin Author Mr. Vibe

    @wpthemes

    @anaeme: did this work?

    I have to delete the whole plugin and re install it?

    The slider is working on my site, but I’m still having problems. When I clicked “Save settings” the changes that I made were reverted… and the navigation buttons disappeared… (apologize for my English…)

    didn’t work… I’m not able to change the settings…

    Dear Mr. Vibe. I just update a newer version and I have exactly the same problem.

    The whole website is not working by now and it shows:
    Fatal error: Call to a member function generate_theme() on a non-object in /homepages/6/d380626310/htdocs/wsb6520773201/wp-content/plugins/vslider/vslider.php on line 59

    Could you please help me with that.

    Thank you.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] [Plugin: vSlider Multi Image Slider for WordPress] Fatal Error after updating to vSlider 4.2’ is closed to new replies.
Skip to toolbar