Support » Plugin: Easy Table of Contents » Plugin vs Avada Theme

  • Hi,

    I’m not sure if this is from Avada or their Fusion Page Builder (I’m thinking it’s fusion) but if I have animations enabled for graphics to drop in on page load… they don’t show up unless I disable your plugin. For now I just removed the animations but I’m guessing it’s a jquery conflict or something? Any ideas of a fix so I can enable the animations again?

    It’s too bad your plugin doesn’t have a checkbox to disable all your plugins scripts from pages that have it explicitly disabled or pages not using it.

    Also, on the page that I am loading your TOC it seems to load kinda slow. It starts with the TOC totally open and revealed and then closes it once the page is loaded which is kinda lame. Not sure if that’s expected or what is causing it.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Steven

    (@shazahm1hotmailcom)

    @johnsimoneau

    RE: I’m not sure if this is from Avada or their Fusion Page Builder (I’m thinking it’s fusion) but if I have animations enabled for graphics to drop in on page load… they don’t show up unless I disable your plugin. For now I just removed the animations but I’m guessing it’s a jquery conflict or something? Any ideas of a fix so I can enable the animations again?

    Sounds like it might be related to this thread… different theme and visual builder though.

    https://wordpress.org/support/topic/problem-with-visual-composer-6/

    Do you know if Fusion uses Waypoints? And if it does, do you know know if it is current?

    Or

    Are you running Really Simple SSL?

    RE: It’s too bad your plugin doesn’t have a checkbox to disable all your plugins scripts from pages that have it explicitly disabled or pages not using it.

    The scripts should only load on pages where the TOC in inserted or where the TOC widget is used. On my dev site I see that is not the case. I’ll take a look and correct that bug.

    RE: on the page that I am loading your TOC it seems to load kinda slow.

    I could not find a page on your site with a TOC… Could you share a link to the exact page where you are using TOC?

    I did notice the slow page loading on the pages I did visit. The largest factor in the page load speed was the size of the images you are loading. I do not mean the width*height size. I mean the file size. Your pages are in the megabytes, largely due to image sizes. You should look at optimizing your images for better page loading performance.

    RE: It starts with the TOC totally open and revealed and then closes it once the page is loaded which is kinda lame. Not sure if that’s expected or what is causing it.

    Yes, the TOC is rendered to display and then, based on settings, it then hidden. The reason is that I find many, many, many sites with broken javascript causing fatal errors which prevents coded loaded after the error from running. Since the javascript for the ezTOC is load last (or close to last) this would mean if there were an error and the TOC was rendered “closed” then it could not be shown to the user.

    Additionally, it is displayed open by default for users which browse the web with javascript disabled. This way they would still see the TOC without having to enable javascript.

    Although I have specifically researched it, I suspect this is also good for accessibility.

    That said, this functionality will not change.

Viewing 1 replies (of 1 total)
  • The topic ‘Plugin vs Avada Theme’ is closed to new replies.