WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Visual Form Builder] Two Problems with the Recent Upgrade

[Resolved] [Plugin: Visual Form Builder] Two Problems with the Recent Upgrade

  • bluebird2
    Participant

    @bluebird2

    There are two problems with the recent upgrade:

    1. The icon on the top of the post textbox is a broken image link. It does not show up because it is linked to “visual-form-builder-pro” instead of “visual-form-builder”.

    2. Why do we need a “fieldset” there in every form. If this is something that technically needs to be there it is better to have it automatically there without the user’s intervention. This “fieldset” has changed the style of the forms. In my case it forced me to stop using this plugin.

    http://wordpress.org/extend/plugins/visual-form-builder/

Viewing 6 replies - 1 through 6 (of 6 total)
  • bluebird2
    Participant

    @bluebird2

    One more problem: styles in “visual-form-builder.css” overrides the new styles defined in the child theme. I could not even style the form using the style fields within the form.

    Plugin Author Matthew Muro
    Participant

    @mmuro

    Thanks for reporting the bug about the media button image. I’ll get a fix out for that today.

    As for #2, an initial fieldset is necessary in order for the form to function and render correctly. Would you I rather automatically add a fieldset you can’t customize? Or would you rather be notified that a fieldset is missing and give you the opportunity to add one and do what you wish with it. If you want to leave it blank, that’s fine, but you need one.

    bluebird2
    Participant

    @bluebird2

    It adds a text there and makes the whole form to be placed in a grey box. One cannot have a form without a title. I have no problem adding one there as long as it could be hidden.

    Plugin Author Matthew Muro
    Participant

    @mmuro

    Check out the screenshots for what a form looks like: http://wordpress.org/extend/plugins/visual-form-builder/screenshots/

    You are welcome to customize the CSS to fit your style. If you don’t like the text of that first fieldset displayed, then simply leave the Name of that field blank and it won’t be displayed.

    bluebird2
    Participant

    @bluebird2

    If I ger rid of the “fieldset” the problem of styling is still there. Please see the screenshot here:
    http://i.imgur.com/nSvGs.png
    I could not change the style by adding new styles to my Child theme CSS file or adding new styles to the “Style” textbox within the plugin.

    By the way in the admin the “fieldset” looks weird after removing the text: http://i.imgur.com/1Keer.png
    I think it would be good to have an option to hide it instead of removing the text.

    cloc562oc
    Member

    @cloc562oc

    I was having the same issue with the fieldset being required. The only documentation i could fins to help me fix it could be found here
    web design la habra | Visual Form Builder Remove Fieldset
    Was exactly what i was looking for hopefully it helps your or somebody else out there.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: Visual Form Builder] Two Problems with the Recent Upgrade’ is closed to new replies.