Visitor Maps and Who's Online
Install permissions (7 posts)

  1. Bytelab
    Posted 5 years ago #

    I have installed the Visitor Maps plugin - it now shows a message at the top of my WordPress admin consol as follows:

    Visitor Maps plugin needs the Maxmind GeoLiteCity database installed. Install Now

    When I click on Install Now i am redirected to a page displaying this message:

    You do not have sufficient permissions to access this page.

    I am using my admin account on WordPress - this is the account I created the environment with - it is the only account I run.

    Please help! Many thanks.

  2. Mike Challis
    Plugin Author

    Posted 5 years ago #

    It might be a wordpress session cookie problem. Try log out of admin. Then log in again. or try another web browser.

  3. mcfri
    Posted 5 years ago #

    I have such a problem too (with manual upload no problem). I like to use the automatic update...

    Error message:
    Visitor Maps
    Preparing a first time install of the Maxmind GeoLiteCity database
    PHP Memory Limit is 256M, increasing is not needed.
    Connecting to this URL: http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz

    Please allow plenty of time for the approximately 19meg file to download.
    The time needed depends on your server download speed.
    A timeout can happen if the connection is really slow causing this to take more than 3 minutes.

    Warning: fopen(/var/www/vhosts/--the-domain-name--.com/httpdocs/wp-content/plugins/visitor-maps/GeoLiteCity.dat.gz) [function.fopen]: failed to open stream: Permission denied in /var/www/vhosts/--the-domain-name--.com/httpdocs/wp-content/plugins/visitor-maps/class-wo-update.php on line 415
    download_file error: cannot write to file, check server permission settings

    PS: Mike, I like the plug-in! well done!

  4. Bytelab
    Posted 5 years ago #

    I managed to fix this by deactivating it, renaming the plugin folder on the server, logging out, logging in, renaming the folder to the original name & reactivating.

  5. mcfri
    Posted 5 years ago #

    I tried this... no effect... still the same error. I hope Mike has an idea ;-)

  6. Mike Challis
    Plugin Author

    Posted 5 years ago #


    If the geolite database errors trying to download, the server's PHP
    settings could be the cause. Possible reasons: PHP safe_mode could be
    enabled, you should turn it off. allow_url_fopen could be disabled, you
    should turn it on.

    If you can, edit your PHP.ini file (usually located in /etc/php.ini or
    the root folder of your web site) and make sure these two settings are
    like this: safe_mode = Off, allow_url_fopen = On
    see also:

    The geolite database is really just a 30 meg file. As a workaround,
    you can manually download the GeoLiteCity.dat.gz file from this URL,
    unzip it and upload GeoLiteCity.dat to the /plugins/visitor-maps/
    folder. The GeoLiteCity.dat file is the database for the location from
    IP feature. If the file is missing, the blog should function fine.
    When the file is not installed, the location information for a user is

  7. kay9
    Posted 4 years ago #

    Hi Mike, if you check this thread, can you help me with an error?

    I get this every time you issue an update and it tells me to upgrade the database. My server says safe mode is off but I can't tell about the other stuff; I guess I don't have access to php.ini? Anyway, this is the error I get in my WP admin area:

    Warning: fopen(http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz) [function.fopen]: failed to open stream: Connection timed out in /home/foo/public_html/sitename/wp-content/plugins/visitor-maps/class-wo-update.php on line 414
    download_file error: reading or opening file

    Appreciate any help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Visitor Maps and Who's Online
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic