Support » Plugin: videopress » [Plugin: videopress] VideoPress embeds not playing on click, JS error?

  • Resolved jolaedana



    Decided to post here, because it has been almost 48 hours and I have not heard back from VideoPress tech support regarding the video player on my client’s site not working.

    I am working with my client to get videos working on their blog, which is a privately hosted WP blog working with a account set up with the VideoPress upgrade.

    Right now, the videos embed, but won’t play on click- you can see this in a blog post we have set up:

    • In Firefox, the error reports as “JQuery.type is not a function. videopress.js?=ver1.07 line 10.”
    • We are running WordPress 3.0 and the latest version of VideoPress. We can not upgrade our WP install because the in house server is running PHP4.x. (At least I don’t think. If someone’s positive one of the minor versions won’t hose our install, I’d be happy to upgrade to it.)
    • I have turned off all other plugins, and VideoPress still doesn’t function. (They are currently back on.)
    • I have checked our theme to make sure that we are not calling in JQuery anywhere else, and we aren’t.
    • I have checked permissions on the VP files, and all looks okay.
    • I have uninstalled and reinstalled VideoPress manually to make sure there wasn’t a corrupt file, no joy.

    I can’t think of what else to try other than going back to older versions of the VideoPress plugin, as I’m thinking it may be a compatibility issue with 3.0 for lack of a better idea.

    Googling the error seems to suggest it might be a corruption in a packed JS file, or something else beyond my control.

    Does anyone have any thoughts I haven’t had yet? My client’s already tried three or four solutions, and wasn’t happy with the performance of any of them, and I would really like to make this one stick.

    Thanks for your time!

Viewing 4 replies - 1 through 4 (of 4 total)
  • This is getting unreal. I understand this is a free forum, but VideoPress is a paid plugin for self hosted WP blogs, and I have submitted two support tickets and no response after nearly 6 days.

    I am thinking my client will be getting his money back and we’ll just resort to another solution.

    Finally got a response back from VideoPress folks, right before canceling. The fix, for those of you who might have the same issue, is the following:

    Thank you for the bug report! We’ve fixed this on the side, and will be releasing a new version of the VideoPress plugin that takes advantage of the fix soon.

    In the mean time, if you’re familiar with editing plugins, you can manually apply this fix by opening wp-content/plugins/video/video.php, going to line 229, and changing the ‘1.07’ to 1.08′.

    I installed the 1.5.3 and still have the same issue: the video with the shortcode shows in the page but doesn’t work. I checked the line and in my plugin it says ‘1.09’ so it’s been updated again.

    The problem I see is that it doesn’t insert the video (shortcode) in the post/page.

    By the way, if I put the embedded code the video works, but it’s quite cumbersome. I need the shortcode to work.

    I decided to go with Videopress thinking everything would have worked smoothly with WP. But if support is lacking I probably have to go with Vimeo (same price and great support).

    Hope someone from Automattic will reply.


    I discovered the problem and it’s my fault. I put the shortcode inside another shortcode and shortcodes in WP aren’t working one inside the other. When I used the shortcode on my website outside the shortcode the video worked. So 1.5.3 works as expected.

    This means that for this specific website I have to use the embedded code and since I don’t want the video to be shareable I shall first make it shareable in my blog, copy the embedded code and then make it not shareable. Cumbersome.

    Is there another way to get the embedded code?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: videopress] VideoPress embeds not playing on click, JS error?’ is closed to new replies.