WordPress.org

Forums

Video.js - HTML5 Video Player for WordPress
[resolved] [Plugin: VideoJS - HTML5 Video Player for WordPress] Doesn't work (44 posts)

  1. evaneckard
    Member
    Posted 2 years ago #

    I did read through that. I can get the video to play in FF - still no dice in IE9. I've set the mp4 to fast start, added the htaccess edits, etc. I just get a frozen loading animation after clicking the play button

  2. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    How did you encode your mp4? What program, codec, etc?

  3. evaneckard
    Member
    Posted 2 years ago #

    Video came from a client as mp4. I ran it through WinFF w/ your presets, then used "MP4 FastStart" to set to fast start

  4. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Did you re-encode the mp4 as well? I had a similar issue the other day where I dropped in an mp4 someone else had given me. Worked fine in Chrome, but not the other browsers. I re-encoded with ffmpeg/winff and it works fine now.

  5. evaneckard
    Member
    Posted 2 years ago #

    I did with WinFF using the HTML5/H264 preset. Don't know what else to try... I even re-exported using premiere as an H264 mp4.

  6. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Can you post a link to your site?

  7. judySimon
    Member
    Posted 2 years ago #

    i am also having problems with firefox and ogv/ogg files. chrome and IE work fine.

    i am using the shortcode version of the plugin, so in my code it looks like:
    echo do_shortcode('[video mp4="http://debate.co.il/wp-content/uploads/2012/12/5-base-of-presentation.mp4" ogg="http://debate.co.il/wp-content/uploads/2012/12/5-base-of-presentation.ogv" preload="auto" autoplay="true" width="340" height="250" id="selVideo" class="right" controls="true"][/video]')

    in chrome the src="" gets loaded properly, but in FF i get the following empty video tag:

    <video id="selVideo_html5_api" class="vjs-tech" data-setup="{}" autoplay="" preload="auto" poster="" tabindex="0"> </video>

    what happened to my OGV src tag?

  8. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Do you have a demo page I can look at?
    Have you tried changing the extension from .ogv->.ogg?
    Did you try adding the proper mime types to your .htaccess?
    Does the .ogg src appear in Chrome if you view source, or just the .mp4?

  9. judySimon
    Member
    Posted 2 years ago #

    Hi Dustin,

    1. no demo page, but i can send a u/p to your regular email with insturctions.

    2. can i really just switch the extension without reformatting it??

    3. yes, its in the .htaccess file at the root level, but they are outside the begin-end wordpress tags - see below - does that matter?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    AddType video/webm .webm
    #AddType video/ogg ogg
    AddType video/ogg ogv
    AddType video/mp4 .mp4

    4. just the src= mp4 shows in chrome.

    One other thing, the popout to fullsize works in FF and IE, but not chrome - just to make life interesting ;-) .

    Thanks so much for the help

  10. judySimon
    Member
    Posted 2 years ago #

    one update: i actually tried to put ONLY the ogg in the shortcode, and it didn't work that way either...

  11. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Unfortunately I don't have much time to spend on free support right now, but I will recommend the following:
    1. I always use .mp4 (not .m4v) and .ogg (not .ogv) for my video files. Not sure if this matters or not to Video.js and the web browsers, but the different extensions may suggest a codec is being used which isn't compatible with some browsers.
    2. Try adding the following lines to your .htaccess (note the placing of the .s and that the one line isn't commented out):

    AddType video/ogg .ogv
    AddType audio/ogg .ogg

    3. Its possible that there is some sort of browser detection issue. I'm only the author of the WordPress plugin, not Video.js itself. Its possible this is related to Video.js, not just the WordPress plugin, so you may want to ask for support using the video.js tag at Stack Overflow.

    Best of luck, if I do think of or find anything else I will let you know.

  12. judySimon
    Member
    Posted 2 years ago #

    hi,
    thanks for the reply and i realize that you can't do free support but i just wanted to check if its the wordpress plugin or the video.js that looses the src= tag when converting from the shortcode to the actual video tag...

    this has been very frustrating as i've checked all the answers and aside from adding those lines in the .htaccess file, none has any other concrete answers.

    btw, my .htaccess file now looks like [and it still doesn't work:

    AddType audio/ogg .oga .ogg
    AddType video/ogg .ogv
    
    AddType video/mp4 .mp4
    AddType video/webm .webm
  13. judySimon
    Member
    Posted 2 years ago #

    I got it working...! i made the following changes in the video.min.js file included in your plugin:

    var techOrderArr = ["html5","flash"];
    if (navigator.userAgent.indexOf("Firefox")!=-1) techOrderArr = ["flash","html5"];
    
    VideoJS.options={techOrder:techOrderArr,....

    according to the following post:

    http://www.walmik.com/2012/12/solution-for-videojs-not-playing-some-videos-in-firefox/

    hopes this helps someone else!

  14. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Glad to hear you got it working. Unfortunate that you had to change the video.js source as it could break with future updates. You may want to notify the creator of video.js and let him know -> http://www.steveheffernan.com/.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Video.js - HTML5 Video Player for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic