Support » Plugin: VéritéCo Timeline » [Plugin: VéritéCo Timeline] Wrong Year

Viewing 9 replies - 1 through 9 (of 9 total)
  • I just installed it, and I love it too, but I’m having the same problem. I notice that many of the sample sites they feature also exhibit this problem, but not all of them. Perhaps it depends on whether the timeline is expressed in JSON or a Google spreadsheet. I’m about to dig into the code…

    That’s a good theory. I bet you’re right. I just wish I knew enough to use JSON instead of Google docs.

    Yeah, but for this relatively minor bug, it’s a great plugin. I really like the convenience of dynamically maintaining the timeline in a Google spreadsheet; it’s a bit of a pain to have to convert to JSON. I haven’t tested the theory yet, but here’s a handy little tool you can use to convert CSV text to JSON: http://www.cparker15.com/code/utilities/csv-to-json/. Meanwhile, perhaps a member of the development team will see this thread and come up with a fix. They deserve kudos for a great product!

    Thanks so much for the update! Since I have no idea what I’m doing when it comes to JSON, I’ll just have to wait and see if it can be fixed for those of us using a Google spreadsheet.

    Hey caseymcspadden, did you happen to have any luck?

    So it has nothing to do with the file format. I tested the plugin on MAMP using a JSON file and it worked fine except for the 1957 failure.
    Now I uploaded it but it doesn’t stop loading even though I used the same files. Strange…

    Here’s what ended up working for me: I simply removed the “start” from the first entry in the Title Slide column, and now it works like a charm…

    Removing the start doesn’t work for me via JSON. Even using the example JSON from the TimelineJS download at https://github.com/VeriteCo/TimelineJS doesn’t work. The first slide displays 1957 in the back navigation. But, if I go a couple slides ahead and then back, the year changes to the earliest date in my timeline. Has anyone figured out a workaround for this issue? Ideally, I would like to just hide the date on my first slide (which is a title slide for my timeline).

    Thanks!
    Scott

    I had the same problem using JSON from WP posts and for me it was the date format in timeline.php which caused the bug. I changed the date() to date_i18n() and everything worked ok for me. Will it work for you?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: VéritéCo Timeline] Wrong Year’ is closed to new replies.