Support » Plugin: VéritéCo Timeline » [Plugin: VéritéCo Timeline] PARSING DATA ERROR

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Miguel Peixe

    (@miguelpeixe)

    Are you using JSON or Google Spreadsheet? Can you send the source so I can take a look?

    Google spreadsheet.

    Uploaded latest 0.9.7 Same error

    What’s your email?

    Plugin Author Miguel Peixe

    (@miguelpeixe)

    Hello Miguel, did you get the spreadsheet invite?

    I’ve found that the js files are out of date to the actual version on-line. It therefore
    uses a new google spreadsheet format.

    Go to http://timeline.verite.co/, download the latest version (or grab from github) and
    replace the js/timeline*.js files in the plugin subdirectory.

    using the plugin with wordpress 3.4.1., i also get the parsing error.

    I was getting the error and searching for an answer with no luck. I went back and republished and then when I added the link to the EMBED GENERATOR, I did NOT click the wordpress plugin. Then I just copied the embed code onto the widget and it is working fine. Only up for a few hours so I’ll give an update if it stops working.

    Thanks a million spencerwestwood I replace the files which you suggested and it is working now 🙂

    Im trying also to include the code in a wordpress post but all I get is parsing data again an again.

    But when I use the iframe method it shows it quite well.

    It would work for me but i need to be able to access the css file so as to personalize the timeline a bit.

    What am I doing wrong ?

    [timeline font='BreeSerif-OpenSans' lang='es' src='https://docs.google.com/spreadsheet/pub?key=0Ag0msRI0zk5_dE92WS1ycGI5SnQyMlpYTFFHa1NidFE&single=true&gid=0&output=html' start_at_end='true' ]

    Well I had exactly the same problem. I am not pleased of replacing the JS files directly because I am not sure that tomorrow things will not change again in the Google API. So, why not using just the iframe statement without the wordpress extension ? As soon as something change they will update their extension, right ?
    Here is what I have done and it works very well for me : I uninstall the VéritéCo extension and implement a shortcode function to mimic the extension. Following is the code I have add in my functions.php file

    // Shortcode to use with the iframe of VéritéCo Timeline
    function timeline_shortcode( $atts, $content = null ) {
    	extract( shortcode_atts( array(
    			 'src' => '',
    			 'font' => 'Bevan-PotanoSans',
    			 'lang' => 'en',
    			 'width' => '100%',
    			 'height' => '650',
    			), $atts ) );
    	return "
    	<iframe src='" . $src . "&font=" . $font . "&maptype=toner&lang=" . $lang . "' width='" . $width . "' height='" . $height . "' frameborder='0'></iframe>
    	";
    }
    add_shortcode( 'timeline', 'timeline_shortcode' );

    Then, I use it like as usually :

    [timeline font='BreeSerif-OpenSans' lang='fr' src='http://embed.verite.co/timeline/?source=0Agl_Dv6iEbDadHdKcHlHcTB5bzhvbF9iTWwyMmJHdkE' ]

    Not all the cases are included in the function but that is sufficient for my needs. If someone improves this function, maybe can you share it ? 🙂

    Just for the record. I find a way to solve this problem.

    Go to the website below.

    https://github.com/VeriteCo/TimelineJS

    Copy and upload files under folder called “compiled” to “wp-content/plugins/timeline-verite-shortcode”.

    And follow the instruction in the website. I used the method below.

    https://github.com/VeriteCo/TimelineJS#using-inline-easiest

    I copied the code in the post.

    You should deactivate the plugin in your website. I don’t know why but it does not work when the plugin is activated in your website.

    Hope it works.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: VéritéCo Timeline] PARSING DATA ERROR’ is closed to new replies.