WordPress.org

Forums

Plugin using old readme? (20 posts)

  1. kfoulks2011
    Member
    Posted 2 years ago #

    Ive written a plugin and released it into repository. When i first released it, I had no problem updating screenshots and updating the readme file contents. Now it seems as if the plugin host site wants to revert to the original readme file and the original screenshots. Can anyone help me?

    Here is a link to my plugin
    http://wordpress.org/extend/plugins/easily-change-admin-color/

    Here is a link to my SVN
    http://plugins.svn.wordpress.org/easily-change-admin-color/

  2. sabinevi
    Member
    Posted 2 years ago #

    I'm having the exact same problem, comforting to know I am not the only one!

    In the WP-admin of my website the update shows up and once updated, it contains the new readme.txt but on wordpress.org the content of the readme.txt is not updated and still shows the info for the old version.
    I ran my readme.txt through the validator and succeeded with 'Flying colors' so I don't think something is wrong there.

    http://wordpress.org/extend/plugins/sabines-zoom-gallery/

  3. kfoulks2011
    Member
    Posted 2 years ago #

    okay great. Glad im not the only one. Im rather new to the plugin svn thing and when something like this happens it throws me for a loop. I guess we will just wait it out together lol. If you discover something, let me know please. =)

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    I know that there's been a lot of server movement on wordpress.org over the past few days. This might have something to do with these problems. I've seen 1 or 2 others with the same problem. It could just a case of waiting for 24 hours to allow any mirrors etc to update but, just in case, I'll flag this up to the attention of the Plugin team.

  5. It's been working for some people.

    If you updated during the time we were upgrading servers, that may be why. When did you update the readme?

  6. @sabinevi:

    Your "Stable Tag" in the readme.txt is incorrect. You have it listed as 0.2.1 but there is no /tags/0.2.1 directory. If the plugin's live version is in trunk, then the Stable Tag should be "trunk". Stable Tag is actually a directory name, not a version number.
    http://plugins.svn.wordpress.org/sabines-zoom-gallery/trunk/readme.txt

    @kfoulks2011:

    Your plugin has an incorrect directory structure. There should not be a subdirectory in /trunk, the plugin files and the readme.txt and everything else should be in the /trunk root itself.
    http://plugins.svn.wordpress.org/easily-change-admin-color/trunk/

    Your Stable Tag is okay, but it's likely that it can't find it properly because of the readme.txt file not being located in /trunk.

  7. sabinevi
    Member
    Posted 2 years ago #

    Thanks for looking into it guys and girls!

    The first commit I did was yesterday evening 20:52 CET+1 , the second 45 minutes later. Today I tried again at 12:22 and 16:25.
    But if it's just a matter of time, I'll wait 24 hours.

  8. But if it's just a matter of time

    It's not a matter of time. If it doesn't update within about 15 minutes, then it's not going to update at all. Updates only happen when changes are made to the plugin's repository.

    Fix the readme.txt to have the correct Stable Tag.

  9. sabinevi
    Member
    Posted 2 years ago #

    Thanks Samuel/Otto for looking into it. I'll work it out.

  10. Per Soderlind
    Member
    Posted 2 years ago #

    I have the same problem.

    As far as I can see, my readme.txt has the correct stable tag:
    http://plugins.trac.wordpress.org/browser/acf-field-date-time-picker/trunk/readme.txt
    http://plugins.trac.wordpress.org/browser/acf-field-date-time-picker/tags/2.0.6/readme.txt

    I also updated my assests/* files yesteday (and they are correct here http://plugins.trac.wordpress.org/browser/acf-field-date-time-picker/assets), but in the plugin directory the previous ones are showing: http://wordpress.org/extend/plugins/acf-field-date-time-picker/screenshots/

  11. Jeff Sterup
    Member
    Posted 2 years ago #

    I'm also having the same problem with http://wordpress.org/extend/plugins/plugin-organizer/. I have validated my readme file and everything is fine. I have had this plugin on wordpress.org for a couple of years and now it is suddenly not updating the plugin page. Something is wrong with the wordpress.org server.

  12. Per Soderlind
    Member
    Posted 2 years ago #

    Yes, had to update my plugin. Everything looks fine after the new commit.

  13. sabinevi
    Member
    Posted 2 years ago #

    Took me a few hours but I finally succeeded!
    I added all versions (0.1, 0.2 and 0.2.1) to the tag-directory, moved the screenshots from the trunk to the assets-folder (they weren't showing up from day one).

    Also I changed Stable tag to Stable Tag in all the readme files.

    I don't know what did the trick but I'm happy it's ok now. Thanks everyone!

  14. Jeff Sterup
    Member
    Posted 2 years ago #

    Ipstenu,
    It doesn't match. When you go to the link in your comment you see up to version 2.6.2 in the changelog but the plugin page only shows up to 2.5.9 in the changelog. Both the readme in the trunk and tags/2.6.2 have the full changelog up to 2.6.2 but the plugin page at http://wordpress.org/extend/plugins/plugin-organizer/changelog/ does not.

  15. Jeff - http://plugins.trac.wordpress.org/browser/plugin-organizer/trunk/readme.txt#L7

    You're telling WP there that you're using 2.6.2 :)

  16. @Jeff Sterup: Your problem was that you made those changes over the last week or so, when we were in the middle of a data center migration and so parts of the directory were being moved from one place to another and other various weirdness.

    Next time, instead of trying to fix it yourself via strange SVN commits and such, just email plugins at wordpress.org and tell them the problem. Easier all around.

    I've given your plugin a kick and you'll notice the changelog looks right now. Had you emailed us about it originally, I could have given it a kick a couple days ago and saved you the trouble. :)

  17. Sudar
    Member
    Posted 2 years ago #

    @Otto,

    Two of my Plugins which I updated in the last couple of days is still showing the old readme. Can you do the *kick* for them? Let me know if I have to send a mail or just posting in this forum is fine.

    The following are the two Plugins that are not getting updated.

    http://wordpress.org/extend/plugins/wp-plugin-reviews/
    http://wordpress.org/extend/plugins/wp-github-commits/

    I posted about it here - http://wordpress.org/support/topic/plugin-homepage-not-getting-updated-after-svn-checkin?replies=2

  18. @Sudar They've been updated. Note that most people do changelogs in reverse order. See our example readme.txt for the correct methodology:

    http://wordpress.org/extend/plugins/about/readme.txt

  19. Sudar
    Member
    Posted 2 years ago #

    @Otto,

    Thanks for updating them.

    Will update the changelogs when I release the next version.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags