Support » Plugin: Black Studio TinyMCE Widget » Plugin uses deprecated function

  • Resolved Dave

    (@dvaer)


    Hi there,

    There seems to be a deprecated function in your plugin. I scanned it with ‘plugin inspector‘, and that said there’s a deprecated function in /black-studio-tinymce-widget/includes/class-compatibility-wordpress.php

    wp_tiny_mce at line 95:
    wp_tiny_mce( false, array() ); 
    Deprecated 3.3.0 Use wp_editor()
    wp_tiny_mce at line 204:
    wp_tiny_mce( false, array() ); 
    Deprecated 3.3.0 Use wp_editor()
    wp_preload_dialogs at line 207:
    wp_preload_dialogs( array( 'plugins' => 'wpdialogs,wplink,wpfullscreen' ) ); 
    Deprecated 3.3.0 Use wp_editor()

    I hope you can fix this in an upcoming version.

    Thank you for a useful plugin

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Marco Chiesi

    (@marcochiesi)

    Hi Dave,
    thanks for your report, but the code you referred is intentionally left there to ensure compatibility with very old versions of WordPress (3.1 and 3.2), and it’s executed only when those versions are detected.
    If you’re running a recent version of WordPress you shouldn’t worry about that code, as it won’t be executed and it won’t trigger any deprecation notice.

    Note: in future versions of the plugin we’ll probably drop support for those very old versions of WordPress and so that code will be definitely removed.

    Hi Marco,

    OK, that makes total sense. Thanks for letting me know, I appreciate it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin uses deprecated function’ is closed to new replies.