Support » Plugin: Usernoise modal feedback / contact form » [Plugin: Usernoise modal feedback / contact form] Funnt Behavior in IE

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author karevn

    (@karevn)

    First of all – thanks for a bug report. I noticed that the button is positioned wrong in IE8 on your site – a fix to be released soon.
    Regarding clicking the button – the only way to fix it completely is to hide the standard Usernoise button and replace it with custom image link, because IE8 does not support block rotation right. In your case (long text), that may be best.

    IE9 should not be affected at all though – as it uses a different positioning technique.

    Ok Thanks. I will wait for the update and meanwhile try to fix the problem by using image.

    Yusuf

    The IE polyfill that is being used to rotate the element doesn’t play nice with hover and position fixed, and seems to be very buggy in IE7/8. My solution was to conditionally make the button position: absolute in oldIE. In css/button.css I added a position ~ line 27. When complete, it should look something like this:

    #un-button.un-left.ie7, #un-button.un-left.ie8, #un-button.un-right.ie7, #un-button.un-right.ie8{
    	filter: progid:DXImageTransform.Microsoft.BasicImage(rotation=3);
    	margin-top: -60px;
    	position: absolute;
    }
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Usernoise modal feedback / contact form] Funnt Behavior in IE’ is closed to new replies.