Usernoise modal feedback / contact form
[resolved] Funnt Behavior in IE (4 posts)

  1. yusufjee
    Posted 3 years ago #

    Hi. Can you visit our site at http://customerforce.com in IE and try clicking on the feedback button on the right (it is titled request a free demo)

    Notice how it is hard to click on the button. I have been trying to fix this issue through CSS but no success. Can you help out with this? I checked on IE9 and 8



  2. karevn
    Plugin Author

    Posted 3 years ago #

    First of all - thanks for a bug report. I noticed that the button is positioned wrong in IE8 on your site - a fix to be released soon.
    Regarding clicking the button - the only way to fix it completely is to hide the standard Usernoise button and replace it with custom image link, because IE8 does not support block rotation right. In your case (long text), that may be best.

    IE9 should not be affected at all though - as it uses a different positioning technique.

  3. yusufjee
    Posted 3 years ago #

    Ok Thanks. I will wait for the update and meanwhile try to fix the problem by using image.


  4. rtvenge
    Posted 2 years ago #

    The IE polyfill that is being used to rotate the element doesn't play nice with hover and position fixed, and seems to be very buggy in IE7/8. My solution was to conditionally make the button position: absolute in oldIE. In css/button.css I added a position ~ line 27. When complete, it should look something like this:

    #un-button.un-left.ie7, #un-button.un-left.ie8, #un-button.un-right.ie7, #un-button.un-right.ie8{
    	filter: progid:DXImageTransform.Microsoft.BasicImage(rotation=3);
    	margin-top: -60px;
    	position: absolute;

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Usernoise modal feedback / contact form
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic