Support » Plugin: User Taxonomies » [Plugin: User Taxonomies] Getting an error while activating the plugin

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Damian Gostomski



    Firstly, apologies for taking so long to get back to you… It seems doesn’t auto alert plugin authors of support requests!

    Can you let me know what version of WP you’re running, as I’d tested it on several version and they all seem to work.
    Does this occur for you on a clean install as well, or only if you have other plugins/a non default theme enabled (if so, can you let me know what theme/plugins are enabled so I can try to replicate).


    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    FYI, you can monitor your plugin support reqs by following

    Plugin Author Damian Gostomski


    Thanks very much Ipstenu – Added to my RSS feed so should be much quicker to respond to support requests 🙂

    I had the same error pop up just now, only mine complained about /wp-includes/rewrite.php on line 51. We’re on 3.4.1… alas, with a ton of plugins installed, but I just tried it on a clean install and saw the same thing.

    Plugin Author Damian Gostomski


    Does the error occur on every page or just specific ones?
    Have you tried going to Settings > Permalinks to flush the rewrite rules?

    @ipstenu – Any idea why there seems to be a 6 day lag on the notifications when following my support RSS feed?


    I was getting this error too. The register_taxonomy function needs to be called on init (

    So, just wrap the example code in a function, call it on init and BOOM:

    function my_register_user_taxonomy() {
        register_taxonomy('services', 'user',
            // your array
    add_action('init', 'my_register_user_taxonomy', 0);

    H/T to Tadlock’s original post for the fix.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: User Taxonomies] Getting an error while activating the plugin’ is closed to new replies.