Support » Plugin: User Registration Aide » [Plugin: User Registration Aide] Unable to add new fields

  • Resolved Mavrouka



    I have just installed version 1.1.4 but, when I am logged in as Admin, I am unable to add new fields. When I select a field and then click on Update Options, I get the message:

    “You do not have adequate permissions to edit this plugin! Please check with Administrator to get additional permissions”

    I would appreciate any advice on how to fix this.

    Also, when I tried to contact you through the Plugin Support on your website, I was denied access by the Stop Spammer Registrations Plugin!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author bnovotny


    Okay, I have security in place to check permissions for the current user to edit plugins, and if not then that message will appear. If you go into the editor for user-reg-aide-admin.php and go to line 328, or a little over halfway down under updating arrays and database options, comment out the line the is : if($csds_current_user->has_cap(‘edit_plugins’)){

    Then make sure you comment out lines 342 to 344

    which go like

    echo ‘<message here (too long to retype now)>

    Once you comment those out which is //, you should be good to go. You should also check on your permissions though, as I have not ever encountered that issue during testing or running. Another question is did you install it or someone else, but I don’t think that that would make a difference. But if your site is secure just comment out those lines above and that will get rid of the problem altogether for you, and if you have any more issues get back to me on my website and I can fix it for you and send you an update. I disabled the stop spammer plugin by the way so you should be able to contact me from the website.

    Plugin Author bnovotny


    For commenting out, it is lines 341-344, need my glasses

    Plugin Author bnovotny


    not 342 to 344

    First of all, thanks for your very speedy response.

    I’m not very PHP savvy but thought that commenting out looked fairly simple, so I tried it and was locked out of admin with an error message – perhaps a case of “a little knowledge is a dangerous thing”? I uploaded the original php file and now all ok.

    If I send you the php file with my amendments via your website, could you please fix it for me – will show me how to properly comment out stuff which would be a bonus too!

    (FYI, I was logged in as Admin when I first encountered the problem. I installed your plugin myself through the Dashboard plugin installer and haven’t changed file permissions which are currently set to 644).

    Plugin Author bnovotny


    Hmm, that is interesting, anyways, just send me your email and I will send you a copy with those lines commented out

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: User Registration Aide] Unable to add new fields’ is closed to new replies.