Support » Plugins » [Plugin: User Photo] There is a bug in this plugin with the ADMIN user

  • Cathy Tibbles


    the author tags default to NOT displaying if is the ADMIN user. The plugin works just fine without any coding except the <?php userphoto_the_author_photo ();?>, then I entered the photo in the user admin panel, and all is well.

    It works just fine if I create a new user for the admin of the blog, and assign her admin priviledges. It must be the initial “admin” that is defaulted to NOT display – which really, this plugin should overwrite in a coming version!


Viewing 7 replies - 1 through 7 (of 7 total)
  • intristin


    yup, same thing happened to me. Was driving me mad as I had no idea what I was doing wrong. Really hope it gets fixed.

    Weston Ruter


    I’m not sure I understand the situation in which the Admin user photo doesn’t display. I just tried assigning a photo to the admin user, and it displayed as expected in the post.



    I had the same problem but instead of playing around with the code what I did was create a new user, assigned to admin, now I log in with that.. It also works better if you use the same user with SMF because the WP admin won’t get logged into the board and the new user does and I assigned admin priv to that one too.



    I have this problem too. My admin user’s photo just won’t show up!

    Yes I too had exactly the same problem as everyone else!

    However I was able to solve the issue after some closer inspection of the plugin settings. So let me just clear up what I think the original poster was trying to tell the developer!

    Firstly I should point out that this is indeed only a problem if you only have a Single User Admin Account! Now the problem with this is, user photo plugin doesnt recognise your default administrator, (you will notice this in the plugin settings after first activation, that there is no admin listed in the drop list menu for notification of photo uploads)

    1: So to get around this problem after you activate it, you have to upload your user photo to the the default administrator via the edit user profile settings.

    2: Then whilst you’re still at the user management, you will have to add another account with Author level access (note: this is the default level of the plugin settings) So create your new user account accordingly and save!

    3. Then logout and log back in using your newly created user account and go back to the user management profile settings. Then select and edit your default administrater’s profile, scroll down till you see your uploaded photo, there you will now see a IMAGE PENDING NOTICE.

    4. SO now you will be able to authorize your custom image for the default admininstrator. Then If you check your blog you should now be seeing your default admin’s photo being displayed in the comments etc!!

    Final note: Personally I find this annoying that the default administrator can not authorize is own image. lol However other than that small issue, this is a most excellent plugin. Thanks! 🙂

    Thanks a bunch, orioneyes!

    I had the exact same problem and wasted an hour trying to figure out why the admin photo wasn’t displaying.

    This issue really should be fixed (ie. the admin should be able to approve their own photo, or even better – have it approved by default)

    Otherwise great plugin!

    LE: forgot to mention that the bug may not replicate 100% — out of two WP installations one worked correctly and the other didn’t. (had to do it Orion’s way) and I have NO idea what I did differently.. sorry 🙁

    Still hasn’t worked for me, and hasn’t worked for others in the forum. Hopefully this will get fixed at some point.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: User Photo] There is a bug in this plugin with the ADMIN user’ is closed to new replies.