WordPress.org

Support

Support » Plugins and Hacks » [Plugin: User Photo] 2 Warnings with WP 2.5 Permission error & Header error

[Plugin: User Photo] 2 Warnings with WP 2.5 Permission error & Header error

  • I’m a very basic novice so I’m not sure if this is something simple that was just fixed in the new WordPress and no one is talking about it any more or what. Does anyone have any suggestions on the below two errors. I can’t even get this plugin to begin to work.

    Warning: mkdir() [function.mkdir]: Permission denied in /home2/guysford/public_html/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information – headers already sent by (output started at /home2/guysford/public_html/wp-content/plugins/user-photo/user-photo.php:409) in /home2/guysford/public_html/wp-includes/pluggable.php on line 694

Viewing 15 replies - 16 through 30 (of 42 total)
  • Hi,

    Same problem here. Is there a line where we can hardcode the directory with the userphoto’s. I just need it for one user.

    Jers and Mafiamoso:
    What are the error messages you are receiving? Did you change the default upload path from “wp-content/uploads”?

    I’ve tried everything and get this error:
    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the /userphoto directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory.

    Do I need to create a folder and if so where? Then exactly what do I put in the upload directory under the Misc tab?

    Thanks!

    Not sure if this will help but trying going to:-

    http://www.yoursite.com/wp-admin/options-misc.php

    go to:

    – settings
    – miscellaneous settings
    and then uncheck

    Organize my uploads into month- and year-based folders

    This may help.

    I have a question as well:-

    How do I use User Photo with wp_list_authors to show current authors with their photo next to them in the side bar

    Thanks

    Jonathan

    jonathan.lyon@gmail.com

    Getting the same errors, I have the default upload setting.

    Warning: mkdir() [function.mkdir]: open_basedir restriction in effect. File(/userphoto) is not within the allowed path(s): (/home:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/public_html/press/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information – headers already sent by (output started at /home/public_html/press/wp-content/plugins/user-photo/user-photo.php:409) in /home/public_html/press/wp-includes/pluggable.php on line 694

    Maybe this plugin doesn’t work with some hosts – could be the PHP setup.

    you have to put absolute path something like that :

    /home/public_html/press/thewayyouwant.

    Yes, either the absolute path from the system root, like:

    /home/public_html/press/thewayyouwant/wp-content/uploads

    Or a relative path from the WordPress install:

    press/thewayyouwant/wp-content/uploads

    Both should be good values for “upload path”

    Maybe I’m a little dense, but I unchecked the box in settings as suggested above. I also changed the upload folder to this wp-content/authors/ and I still get this error in the user page:

    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the /userphoto directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory.

    But I know it’s there I created the folder.

    When I try to upload anyway, I get this error:

    Warning: mkdir(/userphoto) [function.mkdir]: Permission denied in /homepages/37/d253594647/htdocs/nfa/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/37/d253594647/htdocs/nfa/wp-content/plugins/user-photo/user-photo.php:409) in /homepages/37/d253594647/htdocs/nfa/wp-includes/pluggable.php on line 694

    HELP!!! lol 🙂

    my message error:

    Warning: mkdir() [function.mkdir]: Permission denied in /usr/share/wordpress_kmkiRR/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information – headers already sent by (output started at /usr/share/wordpress_kmkiRR/wp-content/plugins/user-photo/user-photo.php:409) in /usr/share/wordpress_kmkiRR/wp-includes/pluggable.php on line 694

    I have the default path wp-content/uploads

    have you put a chmod 777 to wp-content/uploads ?

    @jlyon:
    To use User Photo with wp_list_authors(), I think you could add a filter to the author name before calling wp_list_authors() and then remove the filter after calling it. Otherwise, iterating over all of the authors by hand will always work.

    I have yes

    @jessai & westonruter

    Where does the absolute or WordPress install relative path go? Is it a setting in the plugin somewhere or under WordPress Settings > Miscellaneous ?

    Those weird paths “lib/php:/tmp” are being pulled from somewhere automatically, I’m not sure where. Everyone is getting different random paths so i guess they’re coming from the hosts’ servers.

    Westonruter – any suggestions for me?

    @jamie Birch:
    I think you need to chmod 777 that directory you created; that’s why it’s giving you “permission denied”. But it looks like the “upload path” is not correctly stored in WordPress. Try setting it again in Settings > Misc > Upload Directory

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘[Plugin: User Photo] 2 Warnings with WP 2.5 Permission error & Header error’ is closed to new replies.
Skip to toolbar