Support » Plugin: User Avatar » [Plugin: User Avatar] With v.1.3 my avatars are gone

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Enej Bajgoric

    (@enej)

    Sorry to hear that.

    The new user avatar a modified version of timthumb
    http://www.binarymoon.co.uk/projects/timthumb/

    To render the avatar in different sizes.

    Is timthumb something that works on your system? Let me know if you want to help me debug this.

    hi i have timthumb already in my theme, updating the plugin to 1.3.1 breaks the avatars and a ? is displayed in place of image.

    i have currently turned back to 1.2 which works fine in my case on wordpress 3.1

    Plugin Contributor Enej Bajgoric

    (@enej)

    Thanks for letting me know djkrimp

    I am trying to get to the bottom of this. what happens when you go to the url of the image? What error do you see?

    I believe it is a conflict in the two timthumbs that does not allow the URL to be rewritten properly,

    The URL gives “no file or image found” essentially a 404

    Plugin Contributor Enej Bajgoric

    (@enej)

    That is quite strange. Are you using a windows server?

    Nope its a Linux server

    I could run some tests if you want? Just tell me what you need

    I’m not using timthumb.
    I dont know if this helps you in any way, but here is some properties info of one avatar in both versions of your plugin:

    Version 1.3 avatar properties: (Does not work)
    user-avatar-pic.php?id=2&w=150&radom=1292020122
    http://www.idyrøy.no/iDyroy/wp-content/plugins/user-avatar/user-avatar-pic.php?id=2&w=150&radom=1292020122

    Version 1.2 avatar properties: (Works)
    1291548310-bpfull.jpg
    http://www.idyrøy.no/iDyroy/wp-content/uploads/avatars/1/1291548310-bpfull.jpg

    Now it works.
    I had to chmod folders under uploads/avatars/ to 777 for version 1.3 to work..

    Plugin Contributor Enej Bajgoric

    (@enej)

    @djkrimp Thanks for your offer to help. Can you tell me if

    Do you have a setup that is different from the default.
    especially your wp-content folder is in a different place.

    What kind of permissions do you have set on the wp-content/uploads/avatars folder.

    Apache needs to be able to write and write to it.
    If you go to the url of the picture that is not showing
    it should contain user-avatar-pic.php file and an id. the id corresponds to the user id. Is there a folder in wp-content/uploads/avatars that corresponds to that id?

    my best guess is that there is permissions error somewhere in the setup.

    Thanks again for helping me solve this.
    @sijo55 I am glad you got it to work.

    No i have a standard setup, no modifications.

    In version 1.2 this is the address of the image
    wp-content/uploads/avatars/1/1300260234-bpthumb.jpg

    and in 1.3 here is what i get
    wp-content/plugins/user-avatar/user-avatar-pic.php?id=1&w=16&radom=1300260234

    im gtried what @sijo55 and changed the permissions of the avatars folder from 755 to 777 still no Avatars

    Plugin Contributor Enej Bajgoric

    (@enej)

    What kind of permission do the folders inside the avatar folder have?
    and the files inside the folders?
    Like wp-content/uploads/avatars/1/1300260234-bpthumb.jpg
    Do you also have this file inside of your install
    wp-content/uploads/avatars/1/1300260234-bpfull.jpg

    Cheers Enej

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: User Avatar] With v.1.3 my avatars are gone’ is closed to new replies.