WordPress.org

Support

Support » Plugins and Hacks » User Avatar » [Plugin: User Avatar] No longer works with WordPress 3.4

[Plugin: User Avatar] No longer works with WordPress 3.4

Viewing 15 replies - 1 through 15 (of 24 total)
  • Hello. I installed the plugin v1.4.8 with WP 3.4 (spanish) and PHP 5.3.10.
    The plug-in is great and very useful.

    At first, as it is said in this thread, it didn’t work. But diving the code I found that the problem is the following.

    In the upload pic form, we have this line:
    <input type="hidden" name="action" value="save" />

    I don’t know if this line was useful before, but rigth now it leads to a confusion.
    When admin-ajax.php tries to handle the request, understands that the required action is “save“. This action does not exist so it reaches the die() in the admin-ajax.

    The workaround I found is this:
    In the file user-avatar/user-avatar.php comment this line:
    <!-- <input type="hidden" name="action" value="save" /> -->

    It is in function “user_avatar_add_photo_step1“.

    I repeat, I don’t know if this line is useful because I commented it and the plugin started to work ok.

    Please, may the developers clarify if the line is useful?

    Thanks!

    Perfect, thanks for sharing, it works!

    Wow finally works… but where the developer’s support?

    so thanks juanmatias!!!!

    Thanks for the fix.

    Worked for me too!

    @juanmatias you are my hero for the day! Thanks for sharing mate.

    YES! Thank you Juan. This fix hit the spot. Thank you for sharing.

    let us know how do you solve the problem !!

    YES, I can conform after replacing this line:

    <input type=”hidden” name=”action” value=”save” /> with
    <!– <input type=”hidden” name=”action” value=”save” /> –> it works fine. So commenting or removing it at all makes the script works. Thanks

    Yes this fixed the issue, now if we can only send smoke signals to the devs…

    Nice! +1 for that fix working!

    Thanks great fix!

    Ok, I’m happy that worked for all of you. It would be great to contact the dev team to let them know the fix… so they can add it to a future release.
    Does anyone know how to contact the dev team?

    Thakns.

    Thakns Man.I Like You.

    Hi there …

    yes it works … thanks for the fix 😉

    CU No.Trace !

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: User Avatar] No longer works with WordPress 3.4’ is closed to new replies.
Skip to toolbar