Support » Plugin: User Access Manager » [Plugin: User Access Manager] UAM not working

  • Intially to create custom roles we installed ‘Members’ plugin. Today I installed UAM and no problem during installation.

    I created a new group and added a registered user to that group then configured a page with access to the UAM group created.

    After that, I tried login with the user who belongs to the group.
    There is no edit button anywhere on the page that I originally gave edit permission in the group profile.

    I am a novice user please share your ideas on how I can resolve this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • What you want to achieve? UAM does not paint edit buttons on pages, it does provide user access control – users still have to login to the wordpress backend and there pages, that they are allowed to edit, will be visible for them.

    Usually users can edit all pages, of course this depends on the role you assign to them.

    Maybe you would like to try it the other way around? Restrict access to pages users should not write!

    However, you should describe better, what exactly does not happen – I do not understand what you mean by “there is no edit button anywhere”.

    Thanks @bughunter for your reply.

    We have a set of pages that we want some of the registered users to directly edit them.

    So I installed UAM. Then, I created a new group, in the Role affiliation – Editor, Read access – all and Write access – only group users.

    Using a test user account whose role is currently ‘Subcriber’ I put the user under the new group.

    After that I tried to log in with the test user account and visited the page and also checked the menu in the left hand side – but I don’t know how to edit that page that I assigned access to the group.

    Please tell if I missed anything.

    Thanks a lot.

    Hi there,

    This issue is not completely over till now.

    Things Ive done so far to test UAM.
    a) Created a new user group “A” with
    Read Access: only group users
    Write Access: only group users
    Role Affiliation: none

    b) Created a “testuser” in my wordpress site and included the user to the user group “A”.

    c) Tagged the user group under a new page “X”.

    Now, only the “testuser” and administrators can able to view the page “X” but the testuser can’t able to edit the page.

    The testuser is currently assigned the “Subscriber” role.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: User Access Manager] UAM not working’ is closed to new replies.