User Access Manager
[resolved] fatal error in installation (12 posts)

  1. krysttof
    Posted 2 years ago #

    Installation in localhost with MAMP
    Message : Fatal error: Call-time pass-by-reference has been removed in /Applications/MAMP/htdocs/wpext-user/wp-content/plugins/user-access-manager/class/UamUserGroup.class.php on line 646


  2. krysttof
    Posted 2 years ago #

  3. cevenson
    Posted 2 years ago #

    I've had the error too with a different plugin. Only on the MAMP local site not on a live site so I changed the PHP version to 5.2.17 in the MAMP preferences.
    The plugin works fine now.

  4. krysttof
    Posted 2 years ago #

    @cevenson you'r right !
    With MAMP 2.1.1, with PHP 5.2.17 it's work with any problem !
    Thank's !

  5. Solsikken
    Posted 2 years ago #

    I have the same problem, and do not understand the proposed solution. Will appreciate any help. Thanks.

  6. sjaved
    Posted 2 years ago #

    I have the same problem. Can any one tell my how to change the prefrences of php version. m using wamp. Thanks

  7. Little Boy Running
    Posted 2 years ago #

    Actually the problem comes from a deprecated php code (since php 5.0 it seems) that's in the code of the plugin. PHP 5.4 seems to enforce the deprecation and crash the script. See : http://stackoverflow.com/questions/8971261/php-5-4-call-time-pass-by-reference-easy-fix-available

    2 solutions:
    - Run an older version of PHP, but this seems risky as you may not control the version of PHP available on your host or worse, your client's host.
    - The developer releases a fix for this issue. I guess someone else could deliver a fix to the dev (I don't have the skills myself unfortunately...).

  8. Little Boy Running
    Posted 2 years ago #

    I "might" have found the fix but I need to test it before telling the forum about it...

  9. Zam
    Posted 2 years ago #

    I think i have figured it out.

    http://stackoverflow.com/questions/8971261/php-5-4-call-time-pass-by-reference-easy-fix-available as reference.

    Just remove the word "&" and it will work for you.

    Atleast it is working for me.


  10. marcacer
    Posted 2 years ago #

    Hi, you did not mentioned in which file and on which line you will have the remove the '&"

  11. Peacemaker
    Posted 2 years ago #

    Thank you destinyforever this also worked for me.

    Your error message will tell you either the exact line, or the line below, where you should remove the "&". for me the error said 646, but I had to remove the "&" from 645 (i.e. remove the "& from "&$this").

    After trying to activate again the same error occurred for line 995, so I also removed the "&" from 994 and the plugin activated successfully.

  12. GM_Alex
    Plugin Author

    Posted 1 year ago #

    Fixed since version 1.2.3

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • User Access Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.