Support » Plugins and Hacks » [Resolved] [Plugin: Use Google Libraries] Bug: disables Quick Edit.

[Resolved] [Plugin: Use Google Libraries] Bug: disables Quick Edit.

  • It was driving me crazy trying to figure out why “Quick Edit” suddenly stopped working on me until I discovered that I needed to disable this plugin.

    I’m not sure why, but I haven’t been able to change the Post-date to Schedule a post to appear at a specific time, ever since WP2.0. My work-around has been to go to the List of All Posts and click “Quick Edit” to change the time/date before submitting.

    With “Google Libraries” installed, when I click on “Quick Edit”, the post vanishes from the list (Refreshing the screen brings it back). Only temporarily disabling Google Libraries prevents this from happening. Very annoying.

    Otherwise, the plugin appears to work fine.


Viewing 15 replies - 1 through 15 (of 22 total)
  • I noticed it breaks a number of plugins in wp-admin as well. It also breaks the main dashboard page, you can no longer manage those widgets.

    Anyone have a fix besides using the included jquery with wordpress?

    Plugin Author Jason Penney


    I can’t reproduce, so chances are it’s some other plugin mis-enquing a script (before init). I’m pretty sure that starting with WP 3.3 there should be a message logged when plugins do this and WP_DEBUG is enabled.

    I don’t have the widget problem either.

    If either of you want to give me a list of plugins, or more specific instructions to reproduce I’ll see what I can do.

    Hey Jason,

    I’m using 3.1.2 and sadly we are using about 40 plugins. I’ll debug and get back to you regarding which one is causing the issue. Also, this is a WPMU install, not sure if that has anything to do with it.

    Get back to you soon.


    Hey again Jason,

    You were right, it is another plugin causing the problem, specifically BWP minify ( http://wordpress.org/extend/plugins/bwp-minify/ )

    When using both your plugins together, it creates this in the footer source, the 1.8.9 happens to be the jquery UI version:

    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>
    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>
    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>
    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>
    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>
    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>
    <script type='text/javascript' src='http://xxx.com?ver=1.8.9'></script>

    Let me know if I can provide anything else and thank you.

    Hey Jason,

    I was able to hack this to work, but it’s not really the most ideal solution. If you have any ideas, let me know:

    in use-google-libraries.php:

    $ig = false;
          foreach ($newscripts as $script) {
            $olddata = $this->WP_Dependency_get_data($scripts, $script->handle);
          	$scripts->remove( $script->handle );
          	// re-register with original ver
            // hack: only allow it to enque one jquery-ui, which has version of 1.8.9
          	 $scripts->add($script->handle, $script->src, $script->deps, $script->ver);
            if( $script->ver == '1.8.9' && !is_admin())
              $ig = true;
            if ($olddata)
              foreach ($olddata as $data_name => $data) {

    I went through and tried disabling every other Plugin, but nothing stopped the aforementioned bug (clicking ‘Quick Edit’ results in entry disappearing from the list of Posts] from recurring. ONLY disabling “Use Google Libraries” allows me to access “Quick Edit” normally.

    Problem exists in both Firefox AND MSIE-9, so it is not a browser issue. I will try another OS (currently using 64bit Win7), but I expect the same result.

    (UPDATE: Tried Linux. No difference.)

    Plugin Author Jason Penney


    defunctlife: I’m curious why you have multiple jquery-ui’s enqueued with different versions. That seems a likely to be the root of your problem.

    ‘Use Google Libraries’ doesn’t touch the version. It just takes what WordPress gives it (which is how this plugin usually works fine without any modification between WordPress releases).

    Mugsy: I can’t reproduce the problem. With UGL as the ONLY plugin enabled, and your cache cleared out, you still see the issue? What theme are you using?

    Hi Jason,

    I don’t think I do, I would be happy to send you any further debug information. If I just use “use google libraries” alone, it only loads 1 very jquery, enabling BWP minify seems to interfere with that and cause it to load like 9 times. I’m not exactly sure where the problem lies…

    Plugin Author Jason Penney


    I’ll take a look and see if I can reproduce by adding BWP to my test setup.

    I have this in my functions.php, maybe it helps:

    wp_enqueue_script('jquery', '', '', '', true);
    	wp_enqueue_script('jquery-ui-core', '', '', '', true);
    	wp_enqueue_script('jquery-ui-tabs', '', '', '', true);
    	wp_enqueue_script('jquery-ui-resizable', '', '', '', true);
    	wp_enqueue_script('jquery-ui-draggable', '', '', '', true);
    	wp_enqueue_script('jquery-ui-selectable', '', '', '', true);
    Plugin Author Jason Penney


    Wait, where in your functions.php? Is it in an init hook? If not you’ve probably corrupted the script loader (starting with 3.3 this should be caught when WP_DEBUG is enabled). Also, when enqueueing previously registered scripts, you only do this (or things break):


    In this case what you want is:

    function my_init() {
      // the other scripts you had listed are prerequisites, so just let
      // them load

    No dice 🙁

    Here is my full function, tried making your adjustments: http://pastie.org/2977611

    Thanks for the reply Jason.

    Not sure how to flush the WP cache. I’ve tried disabling every plugin except UGL, and even tried switching to the default WP Theme instead of my own (which only alters the front-end), and it made no difference.

    Plugin Author Jason Penney


    Mugsy, I actually meant after disabling the plugin be sure to clear your browser cache. If you have FireBug installed in FireFox you could see if you get any errors in the console.

    Plugin Author Jason Penney


    I just released a new version (1.2). It changes how UGL handles cases where multiple smaller scripts are merged into a single script on Google’s servers (which was breaking things with the WordPress 3.3 RC, because jQuery UI’s dependency structure is quite different).

    I’m not sure if will effect either of these issues, but could you give it a try and let me know?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] [Plugin: Use Google Libraries] Bug: disables Quick Edit.’ is closed to new replies.