Plugin upgrades not working (17 posts)

  1. dartiss
    Posted 6 years ago #

    I've seen this reported a number of times, always with a temporary solution. I'm curious as to whether there is a more permanent fix.

    Basically, when trying to do an automatic plugin update (or an automatic update of WordPress itself) I get the error...

    Downloading install package from http://downloads.wordpress.org/plugin/[plugin name].
    Unpacking the package.
    Could not copy file /public_html/wp-content/upgrade/[plugin folder and file]

    Obviously, I've removed the name of the specific plugin above, as it's not really relevent.

    The temporary solution is for me to go to the upgrade folder and change the folder permissions to 777. This then works. As soon as I try to upgrade another plugin however, it fails and I have to do the same again.

    Are there any solutions to this one?


  2. scubapro25
    Posted 6 years ago #

    Same thing happens to me, but I get the:

    "Warning: touch() [function.touch]: Unable to create file D:\Hosting\4308252\html/wp-content/google-analyticator.4.3.2.zip because Permission denied in D:\Hosting\4308252\html\wp-admin\includes\file.php on line 175

    Download failed. Could not create Temporary file"

    Error Message

    Complaints to hosting service elicits the 'WP is open source, so we do not support it, stop bothering us,' even though the issue is a 'permissions issue' on THEIR server.

  3. Lovedoodle
    Posted 6 years ago #

    I get the same error as dartiss no matter which plugin I try to install. I'm using WP version 2.6.2.

    Here's what I've tried:

  4. * Changed permissions of the wp-content/plugin/ folder to 777
  5. * Changed permissions of the wp-content/upgrade/ folder to 777
  6. * Uninstalled and re-installed the plugin
  7. After all of that, I still get this error:

    Downloading update from http://downloads.wordpress.org/plugin/custom-field-images.1.9.2.zip
    Unpacking the update
    Could not copy file: /wp-content/upgrade/main/custom-field-images/screenshot-2.png
    Installation Failed

    I use a significant amount of plugins on my blog and it's very time consuming to manually update plugins. If there's a way to fix this feature, I'm all for it.

  • stallan54
    Posted 6 years ago #

    I get this message below: Very frustrating...wha'ts the fix?/

    Downloading update from http://wordpress.org/wordpress-2.8.zip

    Unpacking the core update

  • Lovedoodle
    Posted 6 years ago #

    Um, I don't think that's the same issue....

    Why do we get the message:

    "Could not copy the file"
    "Installation Failed"?

    when updating PLUGINS??

  • Algeriano
    Posted 6 years ago #

    Any solution guys?

  • bumblybee
    Posted 6 years ago #

    I also have this problem. I have two almost identical blogs (with two separate hosting companies) and one works perfectly fine and the other seems to fail at automatically upgrading plugins and WP itself. I usually get an error about failing to copy a particular file when upgrading plugins.

    The only difference I noticed is that the problem blog asks for connection information before upgrading whereas the other blog does not.

    I was making do with Fantastico to upgrade my WordPress install but I'm now put off doing that after reading a post earlier in this thread. I decided to email my host as I had numerous plugins crying to be upgraded.

    Thankfully they were very helpful (unlike my previous host who shrugged off any problem as an issue with the software and not them) So far my plugins are upgrading again. Unfortunately, they didn't tell me what the problem was or how they fixed it so I'm not really able to help anyone. If you are on shared hosting though, it's worth getting in touch with them.

  • ccherrington
    Posted 6 years ago #

    I am having a similar problem trying to get a new theme uploaded. I get this message:

    Warning: touch() [function.touch]: Unable to create file D:\Hosting\4931657\html/wp-content/gemer.1.0.2.zip because Permission denied in D:\Hosting\4931657\html\wp-admin\includes\file.php on line 175

    Download failed. Could not create Temporary file

  • Lovedoodle
    Posted 6 years ago #

    This issue (plugin upgrades) seemed to be fixed, when I upgraded from 2.6.2 to 2.8.4. I assumed it was because of some customizations I forgot about that I made in the core files. Try re-installing wordpress or upgrading.

  • dartiss
    Posted 6 years ago #

    No, sorry, still an issue under 2.8.4. I'm still getting this error whenever attempting to automatically update any plugin.

  • iPhoneism
    Posted 6 years ago #

    Never gives any errors for me, but it used to work just fine, but with that last update it always shows this pop-up with the code for the plugin and doesn't install it?

  • whenyou
    Posted 6 years ago #

    OK! I had a similar problem wil All-In-One-SEO (sp) and it took a while for my Host and I to sort it out. The instruction that I (me) was given, to pass to my Host, was as follows:

    1 "This error indicates that your host has enabled the PHP open_base_dir setting on your server. Your host needs to add your WordPress and/or All in One SEO Pack installation folder to the allowed paths for this setting (i.e., add the file path referenced in the error as 'not within the allowed path').

    The open_base_dir setting is primarily used to prevent php scripts for
    a particular user from accessing files in another user's account. So
    usually, any files in your own account should be readable by your own
    For Reference:

    2/You're getting the error because one of the changes in this plugin is to have the SEO class in it's own file. Including that class isn't
    allowed by your paranoid host. You're going to have this problem with a lot of plugins.

    & etc.

    We got it sorted but I have not tried any 'automatic upgrades' since then. My Host left SEO Upgrade in the installed condition (he also found a syntax error in a folder name, which caused a problem for the Plugin to be able to 'Activate'. Specifically, a _ instead of a - in the file or folder name of all-in-one-SEO.php [for instance])

    I'm happy with my Host but Plugin Programmers, I think, should be aware of this type shortcoming and rather than advise us to go to THEIR preferred Host, give practical advice and some notice of this particular bug. I looks from this thread that I am not the only one taken by surprise.


  • billydec
    Posted 6 years ago #

    I can't get the plugins to update automatically either. called my host and they said all the settings look OK but there seems to be a problem with file class-pclzip.php on line 2702

    does that help identify the issue? If so... please help.


  • Jehy
    Posted 5 years ago #

    ccherrington and others with "Download failed. Could not create Temporary file" error - try this, worked fine for me.

  • riffard
    Posted 5 years ago #

    I think you might have to go and change the permission of your database user. You want to select a dba (database administrator). That way, WP will be authorized to create tables, folders on the sorver, etc...

  • gadgettraveler
    Posted 5 years ago #

    If you are using Windows hosting and on GoDaddy.com check out the solution on this post

  • udey
    Posted 5 years ago #

    Hi all,


    I was facing a similar problem while installing themes and was running the latest version of WordPress (Version 2.9.2).

    I tried various themes, all which couldn't get installed or copied.

    So finally, I gave all the rights to the database user.
    Still the problem existed.

    And I was installing the themes from the Dashboard of the WordPress.

    Went to the File Manager in my hosting service provider.
    Gave all the rights to all the folders - which them appears as 777

    Now installed the same theme that gave the error and it got installed and seems all set to go.

    Best Wishes,

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic