Plugin update fail, image upload fail, plugin install fail (3 posts)

  1. gforeman
    Posted 2 years ago #

    Hi guys,
    None of my plugins will update through WordPress all of a sudden. Additionally, I can no longer upload media.

    I tried for hours to fix it myself and couldn't get it going and I couldn't find a solution on Google.

    I've checked the permissions on all of my folders and everything
    is correct. I've tried adding different codes to my files and nothing works.

    Additionally, nothing has changed from my end. It was working fine a couple of days ago and I haven't updated, uploaded, altered anything since.

    This is the error I get when attempting to update plugins:

    Warning: touch() [function.touch]: Unable to create file /home2/ffpressc/public_html/wp-content/uploads/jetpack.tmp because No such file or directory in /home/ffpressc/public_html/wp-admin/includes/file.php on line 179

    Warning: unlink(/home2/ffpressc/public_html/wp-content/uploads/jetpack.tmp) [function.unlink]: No such file or directory in /home/ffpressc/public_html/wp-admin/includes/file.php on line 493

    Then, I get this error when attempting to upload media files:
    “Xxxxx.jpg” has failed to upload due to an error
    Unable to create directory uploads/2013/04. Is its parent directory writable by the server?

    Any suggestions would be hugely appreciated.

  2. The other part of the file permissions equation is file ownership. You probably need to check the user:group ownership settings. Your web host should be able to help you with this. If your managing your own server this will depend how your running PHP and your Linux distro. For Debian or Ubuntu the settings are usually www-data:www-data.

  3. gforeman
    Posted 2 years ago #

    Thanks. I'm with VentraIP. I'll refer them to this forum in the hope that helps. So it's nothing that I can change in cpanel you don't think?

Topic Closed

This topic has been closed to new replies.

About this Topic