Support » Plugin: Simple Image Sizes » Plugin Update Broken

  • Resolved davidkonicek

    (@davidkonicek)


    After updating this plugin, the site as a whole would not work. The site would only show a page saying “Critical error(s) found in CMS module(s). Debug information is available below” followed by a large file that I don’t understand the meaning of. It said there’s information about my server, so I didn’t include it here.

    More importantly probably, I got an error for the following file:
    wp-content/plugins/simple-image-sizes/classes/main.php on line 7

Viewing 15 replies - 1 through 15 (of 16 total)
  • Shotokan Karate of America

    (@shotokan-karate-of-america)

    Similar problem here – after updating plugin to 3.2.0, our site became unavailable returning err code 500. I disabled the plugin (renamed the plugin directory) and site operation is normal again.

    Thanks

    Plugin Author Nicolas Juen

    (@rahe)

    Hello,

    The minimum version of PHP for this plugin is PHP5.6, I use array syntax introduced in PHP5.4.
    What is your PHP version ?

    OK, that must be the problem. I believe I have PHP version 5.3.28. I’ve been trying to get that upgraded to 7+ for awhile, but still waiting on my hosting provider. Once I get that upgraded, I’ll let you know if I still have any issues.

    Shotokan Karate of America

    (@shotokan-karate-of-america)

    PHP 5.3.29

    also 5.3.29 here as well. I just spent a frantic few minutes converting all the []’s back to array()’s to get the website back online

    we too are having some issues with updating our server to 5.6 or later due to the number of clients on the VPS

    had the update mentioned the 5.6 requirement in the patch notes, it would have saved me quite a bit of headache.

    https://pastebin.com/Ep5FM3Et I’ve made my patch available here if you need a quick fix to get it back up again

    Hey WebDragon,

    I just noticed the plugin page does show “Requires PHP Version” although I don’t know when that info was added. For a less stressful fix, I just installed the previous version of the plugin, which I had on a different website. I’m not sure if previous versions are available for download from wordpress.org, but I thought that might help you in the future if that’s an option. Actually, this WP Rollback plugin allows you to install old versions: https://wordpress.org/plugins/wp-rollback/

    hey David,

    Yeah, but it wasn’t in the Release Notes (and should have been) — I always check those before updating, but rarely go back to the plugin page itself during updates.

    the fix itself I posted above took me less than 15 minutes to create. applying the patch is as simple as

    cp simple-image-sizes.patch www/wp-content/plugins/simple-image-sizes/; 
    cd www/wp-content/plugins/simple-image-sizes/;
    patch -p0 simple-image-sizes.patch;

    said patch from above pastebin unified diff.
    [caveat: the above is from memory, so apologies if not 100% accurate]

    Note that on Centos 6 (in maintenance mode until 2020), php 5.3 is the latest stock version. For a lot of us on virtual servers, Centos 6 is still considered “current”.

    php 5.4.16 is the latest version on CentOS 7.

    • This reply was modified 1 year, 9 months ago by morizo.

    Seeing as the only thing I had to change to bring it back into “php 5.3.x compatibility” was to revert the array shorthand notations back to array() and no other advanced features requiring 5.6 or later were present, and given that the long form of array() is not deprecated, I think it makes more sense to revert those changes at this time, providing backwards compatibility for a longer span of time. There’s no speed advantage to the code change, only readability.

    Plugin Author Nicolas Juen

    (@rahe)

    Hello,

    Don’t forget performance and security : http://php.net/supported-versions.php
    PHP 5.3 is not event listed here, 5.4 and 5.5 dead.
    5.6 dead in one year, even 7.0 is dead before 5.6.

    Rahe,

    Centos backports any security fixes, so there’s no real concern there.

    Maintaining backwards compatibility is definitely up to you — but for me, it’s an easy choice between an incompatible plug-in and avoiding a forced complete update of my (multiple sites’) server’s operating environment.

    • This reply was modified 1 year, 9 months ago by jhfrontz.
    Plugin Author Nicolas Juen

    (@rahe)

    Yes, and i’m not willing to support under 5.6 PHP versions 😉

    what do you mean ‘support’; the only difference in the code your plugin uses between the two is the difference between the [] short version of array().

    You DO know how many CentOS 6 servers there are out there, right?

    I mean seriously the cost of maintaining *compatibility* with them is simply a matter of using the array() structure still supported by 5.6 and later.

    if you don’t offer unpaid *support* for older versions, it’s one thing, but maintaining compatibility is so trivial it took me less than 5 minutes to patch your code.

    what do you literally have to lose by maintaining compatibility?

    Offer paid support (if necessary) for versions running on <5.6 and post a sticky to that effect at the top of the support forum. done. win-win.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Plugin Update Broken’ is closed to new replies.