Support » Themes and Templates » [Plugin: UMapper] Problem with iconv_set_encoding and DOMDocument

  • Fatal error: Call to undefined function iconv_set_encoding() in /home/www/motorrad/html/wp-content/plugins/umapper/Zend/XmlRpc/Client.php on line 216

    This message you’ll get if php is compiled without iconv support I think.

    So I removed (commented) the iconv_set_encoding calls, because my page is already running in utf-8, should be no problem.

    But then the next Problem:
    Fatal error: Class ‘DOMDocument’ not found in /home/www/motorrad/html/wp-content/plugins/umapper/Zend/XmlRpc/Request.php on line 357

    I think my reduced PHP (5.3.5) compile doesnt bring all needed classes (php-xml I think). 🙁

    So if you want to use UMapper, be sure that iconv and libxml is compiled into your php installation.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Okay rechecked my PHP compile settings and found:

    ‘–without-iconv’ ‘–disable-dom’

    So if you want to use UMapper, be sure to ‘–enable-dom’ and ‘–with-iconv’.

    😉

    Hi.. will somebody please explain how to ‘–enable-dom’ and ‘–with-iconv’ in details? I don’t know how to change PHP compile settings.

    BR,
    Thomas

    You have to recompile php or install the php modules that are missing.
    Recompile:
    ./configure –help
    – shows you the available compile options
    then
    ./configure –with-your-desired-options
    make
    make install

    Ok, thanks for the info Raufaser 🙂

    While validating my API key I get this message

    Fatal error: Call to undefined function iconv_set_encoding() in /share/HDA_DATA/Qweb/wordpress/wp-content/plugins/umapper/Zend/XmlRpc/Client.php on line 216

    Which is very similar to what this thread is about. Is there a simple solution?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: UMapper] Problem with iconv_set_encoding and DOMDocument’ is closed to new replies.