Support » Plugin: Ultimate TinyMCE » [Plugin: Ultimate TinyMCE] Visual Tab blank in Editor

  • Resolved chefdanroberts


    After activating the v 1.7 plugin if you try to edit anything, the Visual tab in the editor is blank, but the HTML tab is populated. I thought it was a theme issue, but the author saw some 404 errors indicating editor_plugin.js was not found, and suggested manually installing the pluging. Did that, no change. I checked my webserver and the editor_plugin.js is definitely there. Even changed permissions on the the file to 755, no effect. Any ideas?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Josh


    Hmmmm… you are the second person to mention this… unless you are the one who also posted over on my forum 😉

    1. Which theme are you using? Does the theme add any extra buttons or functionality to the tinymce editor?

    2. Were you using a previous version of the plugin which worked properly?

    Try this, if you have the “tinymce in excerpt area” checked… please un-check it, save, and then check the editor.

    1 -> I am using the Feast theme from NetLabs. It does not add any extra editor buttons.

    2 -> No previous versions, mine is a brand new install of WordPress 3.3.1 and no other 3rd party themes have been installed.

    The ‘tinymce in excerpt area’ was not checked. BTW all of the images in the settings area are empty, if that tells you anything.

    Plugin Author Josh


    Hmmm… is your wordpress installation in your root directory? Or is it in a subdirectory?

    A subdirectory. When I installed WordPress using the ISP provided tools, it defaulted to the format wordpress_9999999999.

    Plugin Author Josh


    Okay. I’ll need to look into this and create a test site in a subdirectory and install the plugin there to test.

    So, gimme a few days… as it’ll be kind of time consuming. But I’ll play around with it and post back here with my results.

    Can you try temporarily switching to the default “twenty-eleven” theme, and see if you still get the same problem?

    Thanks for looking into this. I really don’t want to mess with my live website, but I have WordPress for Microsoft IIS installed on an in-house Server running the twenty-eleven theme in a subdirectory (called wordpress)and it seems to work fine. Might be an artifact of the hosting environment? My ISP is Earthlink.

    Any progress?

    Plugin Author Josh


    Well, I’ve talked with multiple clients who use wordpress in subdirectories and none have reported any issues.

    So, this leads me to believe the problem lies with your theme.

    Can you provide me a url where I can download the theme to look at it’s files?

    Hiya! Same thing happening here. Using bones-responsive framework, not in a subdirectory. My other plugins are askimet, gtrans, wordpress SEO by Yost, and WP Total Hacks. The only other piece of info I can offer is that I am using a small function to add custom styles to the tinymce editor, which I will include at the bottom of this post.

    I have disabled my other plugins but that has not helped.

    Oddly enough, though the editor area looks blank, the text is all there! I can use my mouse to highlight the textfield and see all of my text. It is as if the font color has been changed to white? This is only it the HTML editor. I can’t even get the WYSIWYG tab to load. When I click on the ‘text’ tab, the whole box just collapses.

    Anyway- please don’t think that I am complaining 🙂 I just thought that it looked like an awesome plugin, and I am happy that others are able to use it. I was just hoping to provide details with my experience.

    Thank you for your time,

    /*****************  CUSTOM STYLES FOR TINYMCE EDITOR  ***************/
    function themeit_mce_buttons_2( $buttons ) {
      array_unshift( $buttons, 'styleselect' );
      return $buttons;
    add_filter( 'mce_buttons_2', 'themeit_mce_buttons_2' );
    function themeit_tiny_mce_before_init( $settings ) {
      $settings['theme_advanced_blockformats'] = 'p,a,div,span,h1,h2,h3,h4,h5,h6,tr,';
      $style_formats = array(
          array( 'title' => 'Heading Text',         'block' => 'H1',  'classes' => 'section-intro' ),
          array( 'title' => 'Green Button',   'inline' => 'span',  'classes' => 'button button-green' ),
          array( 'title' => 'Rounded Button', 'inline' => 'span',  'classes' => 'button button-rounded' ),
          array( 'title' => 'Other Options' ),
          array( 'title' => '½ Col.',      'block'    => 'div',  'classes' => 'one-half' ),
          array( 'title' => '½ Col. Last', 'block'    => 'div',  'classes' => 'one-half last' ),
          array( 'title' => 'Callout Box',        'block'    => 'div',  'classes' => 'callout-box' ),
          array( 'title' => 'Highlight',          'inline'   => 'span', 'classes' => 'highlight' )
      $settings['style_formats'] = json_encode( $style_formats );
      return $settings;
    add_filter( 'tiny_mce_before_init', 'themeit_tiny_mce_before_init' );

    (function from

    Resolved! (almost 🙂

    A little more googling and it seems that one of the buttons I activated is conflicting somewhere. I am guessing it is the ‘styles’ drop down conflicting with the custom function I am using to add my own CSS classes for my client, whom I don’t want messing with the HTML :).

    It is strange that the conflict would continue though, because part of my debugging was to comment out the function and test- and that did not work. Hmmm.

    I will post back when I pinpoint what is going down.

    Thanks again.

    Conflict was with custom style function trying to access the same drop down. Simply unchecking the “styles” button did the trick.

    Sorry for the hassle- I don’t know why commenting the function out didn’t work. I probably missed something the first time 🙁

    Thank you sir for a great and most useful plugin!

    Plugin Author Josh


    Sorry, I just saw your addition to this post. Always feel free to begin a new post if you need help, and that will help me see it more quickly.

    I’m glad you were able to resolve the issue. Yes, if two functions attempt to modify the same button, it will result in the editor appearing blank. It “freaks out”, and doesn’t know how to properly complete it’s initialization.

    Thanks for posting!!

    badcrocodile – you are an angel. I have been searching everywhere for a solution to this. By just removing that styles button everything showed up. Thank you.

    Ok. I tried to uncheck every button in ultimate tinymce that said style on them. I even deactivated the plugin all together and it STILL has a blank visual tab with no buttons whatsoever. This has been the case for this particular website for several months, and I have just had to guess what it would look like with my limited html knowledge. I am using the Socrates theme. Please help.

    Plugin Author Josh


    Hi drjdewitt,

    Well, if you’ve attempted all the solutions mentioned here… then I’ll probably need to take a look personally at your setup.

    You can use my contact form here:

    Just shoot me a message, including a link to this thread… and we can move forward from there.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Ultimate TinyMCE] Visual Tab blank in Editor’ is closed to new replies.