Ultimate TinyMCE
shortcodes selector not working with customized installation paths (2 posts)

  1. rhertzog
    Posted 3 years ago #

    I get an error when my browsers requests:

    Warning: require_once(../../../../wp-load.php): failed to open stream: No such file or directory in /srv/codemat/web/wp-content/plugins/ultimate-tinymce/shortcodes-editor-selector/editor_plugin.js.php on line 2
    Fatal error: require_once(): Failed opening required '../../../../wp-load.php' (include_path='.:/usr/share/php:/usr/share/pear') in /srv/codemat/web/wp-content/plugins/ultimate-tinymce/shortcodes-editor-selector/editor_plugin.js.php on line 2

    This is because my WordPress installation has the WP_CONTENT_DIR setting set to a directory (/srv/codemat/web/wp-content/) that is not one level below the main wordpress directory (/usr/share/wordpress). So assuming that "../../../.." will bring you to the wordpress directory is wrong.


  2. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 3 years ago #


    Will have this fixed in the next update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Ultimate TinyMCE
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic