Support » Plugin: Ultimate TinyMCE » [Plugin: Ultimate TinyMCE] can't save span style/class in code magic screen – bug?

  • Resolved abbyj

    (@abbyj)


    I may be doing something wrong as I am new to coding.
    In visual editor I am highlighting a line of text and clicking span tag button.
    I then click html code magic button to edit code and span tags are there correctly.
    To the span tag I add style=”question-bold”> or a class, and click update at the bottom of the screen.
    When I’m back in visual editor, I again click on html code magic button and my span style/class is gone.
    I have also updated in html code magic screen and then also updated in visual editor. I then go back to html code magic screen – span style is not there.
    This has happened before, and the only way I could get the span style/class to work was to enter it in code magic screen over and over again until it “takes”.
    Am I doing something wrong or is there a bug??
    thanks

    http://wordpress.org/extend/plugins/ultimate-tinymce/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Josh

    (@josh401)

    Moderator and Editor Customizer

    Hi, sorry you are having issues.

    Well, your code of style="question-bold" is not a proper style and will be stripped out by the editor.

    If you are trying to use an inline style with the span tag, you need to follow proper css syntax… such as <span style="color:black;font-size:20px;"></span>.

    If you are adding a class, it should look like <span class="question-bold"></span>.

    And for an id… <span id="question-bold"></span>.

    Lemme know if this helps.

    yep – I got it. used span class=”question-bold” but I still had trouble entering more than one span class in code magic at a time.
    I found I had to enter one at a time, then click update, then it goes back to visual editor, then clicked update there, then went back to code magic to enter next one. I love code magic but it’d be great if I could click update and it stayed in code magic box and didn’t go back to visual editor til I was done – maybe add a “done” button?
    thanks Josh

    Plugin Author Josh

    (@josh401)

    Moderator and Editor Customizer

    I agree, codemagic definitely has a few “buggy” issues. You might want to experiment using a different browser and see if you get the same results.

    Do you mean you are entering multiple “spans”, each one with one class? Or, are you trying to add multiple classes to a single span tag?

    Hi Josh – multiple spans with same class.I use firefox.

    Plugin Author Josh

    (@josh401)

    Moderator and Editor Customizer

    Okay. I’m in the middle of moving right now.. so it might take a day or two for me. But, I’ll try to replicate the problem and see if I can find a solution or workaround.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Ultimate TinyMCE] can't save span style/class in code magic screen – bug?’ is closed to new replies.