Support » Plugin: Ultimate TinyMCE » [Plugin: Ultimate TinyMCE] Cannot load wp-load.php on non standard install

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Josh

    (@josh401)

    Fixed.

    Thank you VERY much!!

    Actually, I may have been wrong in my prior tip.

    It seems that ABSPATH is actually defined within wp-load.php! Oops.

    Which means that wp-load.php has already been included at that point.

    Meaning, I guess, that the require_once might be superfluous, unless that file is called in a different context somehow?

    Plugin Author Josh

    (@josh401)

    What about this:

    // Hook into WordPress so we can use all the custom functions and global variables
    $file = dirname(__FILE__);
    $file = substr($file, 0, stripos($file, "wp-content") );
    // Require the file
    require( $file . "/wp-load.php");

    Did you get an error with the first code change? If so, do you remember what it was?

    First code change of updating that path didn’t break anything, because at that point wp-load.php had already been included and defined ABSPATH.

    Meaning that the require statement isn’t needed, unless that style.php file is called in a different context where wp-load.php might not have been included.

    Plugin Author Josh

    (@josh401)

    My fault.. I see what you’re saying.

    Okay, I’ll remove it and make sure everything works properly.

    Thanks again.

    No worries, happy to help. 🙂

    Plugin Author Josh

    (@josh401)

    Yep, removing the code still functions properly. I think I “grabbed” that file from one of my other directories.. and forgot to take out the top section.

    Anyways, all seems well now.

    You don’t by any chance know javascript do you?

    I know enough to be dangerous, given half the chance.

    Having a problem?

    Plugin Author Josh

    (@josh401)

    lol… nice.

    Well, I’m trying to incorporate a drag and drop functionality into the plugin so that content editor buttons can be visually “placed”; rather than having to use those pain in the — dropdown selectors.

    I have quite a bit of the foundation already setup… but it’s with the specifics that I start to feel the headache. There are a few bugs and still a little more work to do on it.

    I can send you a beta version and you can take a look…. if you are interested. If so, send me an email using my contact form:

    Contact Me

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Ultimate TinyMCE] Cannot load wp-load.php on non standard install’ is closed to new replies.